summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJoão Paulo Rechi Vita <jprvita@openbossa.org>2013-08-13 01:53:59 -0300
committerTanu Kaskinen <tanu.kaskinen@linux.intel.com>2013-09-29 16:54:36 +0300
commitc706792df756eb2295996306d7ffaa9723dc4a43 (patch)
tree19b8a44f11ba42b4fcc3ecd2a1395aa067f0a96a /src/Makefile.am
parent795e488f2530663a8252ac19f4efd85afd33c903 (diff)
downloadpulseaudio-c706792df756eb2295996306d7ffaa9723dc4a43.tar.gz
bluetooth: Create stub for module-bluez5-discover
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 773a0af83..66ce83409 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1332,6 +1332,11 @@ modlibexec_LTLIBRARIES += \
module-bluez4-device.la
endif
+if HAVE_BLUEZ_5
+modlibexec_LTLIBRARIES += \
+ module-bluez5-discover.la
+endif
+
if HAVE_OPENSSL
modlibexec_LTLIBRARIES += \
libraop.la \
@@ -1421,6 +1426,7 @@ SYMDEF_FILES = \
module-bluetooth-policy-symdef.h \
module-bluez4-discover-symdef.h \
module-bluez4-device-symdef.h \
+ module-bluez5-discover-symdef.h \
module-raop-sink-symdef.h \
module-raop-discover-symdef.h \
module-gconf-symdef.h \
@@ -2041,6 +2047,12 @@ module_bluez4_device_la_LDFLAGS = $(MODULE_LDFLAGS)
module_bluez4_device_la_LIBADD = $(MODULE_LIBADD) $(DBUS_LIBS) $(SBC_LIBS) libbluez4-util.la
module_bluez4_device_la_CFLAGS = $(AM_CFLAGS) $(DBUS_CFLAGS) $(SBC_CFLAGS)
+# Bluetooth BlueZ 5 sink / source
+module_bluez5_discover_la_SOURCES = modules/bluetooth/module-bluez5-discover.c
+module_bluez5_discover_la_LDFLAGS = $(MODULE_LDFLAGS)
+module_bluez5_discover_la_LIBADD = $(MODULE_LIBADD) $(DBUS_LIBS)
+module_bluez5_discover_la_CFLAGS = $(AM_CFLAGS) $(DBUS_CFLAGS)
+
# Apple Airtunes/RAOP
module_raop_sink_la_SOURCES = modules/raop/module-raop-sink.c
module_raop_sink_la_LDFLAGS = $(MODULE_LDFLAGS)