summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorpoljar (Damir Jelić) <poljarinho@gmail.com>2013-12-03 01:09:56 +0100
committerPeter Meerwald <p.meerwald@bct-electronic.com>2013-12-20 13:06:04 +0100
commitd20ee7e7f21a9deed61ac5adb46cc64921e01796 (patch)
tree86257bc74cca6a0501ad76411f9848fa10b0255a /src/Makefile.am
parenta8fea5c468c96b34d62f60062ea260048fd6d36d (diff)
downloadpulseaudio-d20ee7e7f21a9deed61ac5adb46cc64921e01796.tar.gz
log: Add support for the systemd journal
The journal is a component of systemd, that captures Syslog messages, Kernel log messages, initial RAM disk and early boot messages as well as messages written to STDOUT/STDERR of all services, indexes them and makes this available to the user. It can be used in parallel, or in place of a traditional syslog daemon, such as rsyslog or syslog-ng. The journal offers a couple of improvements over traditional logging facilities (e.g. advanced filtering capabilities). This patch adds support for logging directly to the journal using its native API.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 0296b3c02..c89cd6d3c 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -687,6 +687,11 @@ libpulsecommon_@PA_MAJORMINOR@_la_CFLAGS += $(X11_CFLAGS)
libpulsecommon_@PA_MAJORMINOR@_la_LDFLAGS += $(X11_LIBS)
endif
+if HAVE_SYSTEMD_JOURNAL
+libpulsecommon_@PA_MAJORMINOR@_la_CFLAGS += $(JOURNAL_FLAGS)
+libpulsecommon_@PA_MAJORMINOR@_la_LDFLAGS += $(JOURNAL_LIBS)
+endif
+
# proplist-util.h uses these header files, but not the library itself!
libpulsecommon_@PA_MAJORMINOR@_la_CFLAGS += $(GLIB20_CFLAGS) $(GTK30_CFLAGS)