summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 3 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 217ba0d85..4dae29808 100644
--- a/meson.build
+++ b/meson.build
@@ -613,8 +613,8 @@ if x11_dep.found()
endif
# Module dependencies
-
-if cc.has_header('sys/soundcard.h')
+if get_option('oss-output')
+ assert(cc.has_header('sys/soundcard.h'), 'Need header file for OSS support')
cdata.set('HAVE_OSS_OUTPUT', 1)
cdata.set('HAVE_OSS_WRAPPER', 1)
cdata.set('PULSEDSP_LOCATION', pulsedsp_location)
@@ -808,7 +808,7 @@ summary = [
'',
'Enable memfd shared memory: @0@'.format(cdata.has('HAVE_MEMFD')),
'Enable X11: @0@'.format(x11_dep.found()),
-# 'Enable OSS Output: @0@'.format(${ENABLE_OSS_OUTPUT}),
+ 'Enable OSS Output: @0@'.format(get_option('oss-output')),
# 'Enable OSS Wrapper: @0@'.format(${ENABLE_OSS_WRAPPER}),
# 'Enable EsounD: @0@'.format(${ENABLE_ESOUND}),
'Enable Alsa: @0@'.format(alsa_dep.found()),