summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorChristoph Reiter <reiter.christoph@gmail.com>2018-02-06 18:14:08 +0100
committerChristoph Reiter <reiter.christoph@gmail.com>2018-02-06 18:14:08 +0100
commit1de81a939711b9c2edb915b8bd9855ef9db12f02 (patch)
treedc2b4c2064a0f55309a6381773d1e3c07f5875f9 /setup.py
parent32771e7509a266d5cafbfb0965b018ad8c87c530 (diff)
downloadpygobject-1de81a939711b9c2edb915b8bd9855ef9db12f02.tar.gz
setup.py: install .pc file into libdir
To match what the autotools build does.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 918a5654..96a0ceef 100755
--- a/setup.py
+++ b/setup.py
@@ -31,6 +31,7 @@ from setuptools import setup, find_packages
from distutils.core import Extension, Distribution, Command
from distutils.errors import DistutilsSetupError
from distutils.ccompiler import new_compiler
+from distutils.sysconfig import get_python_lib
from distutils import dir_util, log
@@ -730,7 +731,8 @@ class install_pkgconfig(Command):
for key, value in config.items():
content = content.replace("@%s@" % key, value)
- pkgconfig_dir = os.path.join(self.install_data, "share", "pkgconfig")
+ libdir = os.path.dirname(get_python_lib(True, True, self.install_data))
+ pkgconfig_dir = os.path.join(libdir, "pkgconfig")
self.mkpath(pkgconfig_dir)
target = os.path.join(pkgconfig_dir, "pygobject-3.0.pc")
with io.open(target, "w", encoding="utf-8") as h: