summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorChristoph Reiter <reiter.christoph@gmail.com>2018-02-11 16:08:18 +0100
committerChristoph Reiter <reiter.christoph@gmail.com>2018-02-11 17:32:20 +0100
commit21cee6cc4fbc7fb1a28a15840924b0da52b49fca (patch)
tree44ede8be92381e3fee5b4bb84ee7f1c64c51af60 /setup.py
parent7f5aedb6e1f317b33a96d0c77641b95f182b2a47 (diff)
downloadpygobject-21cee6cc4fbc7fb1a28a15840924b0da52b49fca.tar.gz
tests: Make patching in pygtkcompat reversible
Record all the attribute and sys.modules changes and add an API for reverting them after tests are completed. This allows us to run the pygtkcompat tests in the same test process as other tests.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py7
1 files changed, 0 insertions, 7 deletions
diff --git a/setup.py b/setup.py
index c76bc9f2..fd781092 100755
--- a/setup.py
+++ b/setup.py
@@ -458,13 +458,6 @@ class test(Command):
os.path.join(tests_dir, "runtests.py"),
], env=env)
- if not env.get("TEST_NAMES"):
- env["TEST_NAMES"] = "compat_test_pygtk"
- subprocess.check_call([
- sys.executable,
- os.path.join(tests_dir, "runtests.py"),
- ], env=env)
-
class quality(Command):
description = "run code quality tests"