summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorDieter Verfaillie <dieterv@optionexplicit.be>2010-11-03 09:02:30 +0100
committerDieter Verfaillie <dieterv@optionexplicit.be>2010-11-03 10:15:06 +0100
commit3f70f92904c123e6cc40929c0affd3f75d061828 (patch)
tree99dfcef394ae7b718a554b0aaa0ec302f125a02e /setup.py
parent9aa54b65f729c0f3b0e96ab7ff797f87dad6a455 (diff)
downloadpygobject-3f70f92904c123e6cc40929c0affd3f75d061828.tar.gz
setup.py: rearrange imports
Signed-off-by: Dieter Verfaillie <dieterv@optionexplicit.be>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py31
1 files changed, 22 insertions, 9 deletions
diff --git a/setup.py b/setup.py
index 5135a9d7..54937bb4 100755
--- a/setup.py
+++ b/setup.py
@@ -1,21 +1,34 @@
#!/usr/bin/env python
+# -*- coding: utf-8 -*-
#
# setup.py - distutils configuration for pygobject
-#
-"""Python Bindings for GObject."""
+
+
+'''Python Bindings for GObject.
+
+PyGObject is a set of bindings for the glib, gobject and gio libraries.
+It provides an object oriented interface that is slightly higher level than
+the C one. It automatically does all the type casting and reference
+counting that you would have to do normally with the C API. You can
+find out more on the official homepage, http://www.pygtk.org/'''
+
+
+import os
+import sys
+import glob
from distutils.command.build import build
from distutils.command.build_clib import build_clib
+from distutils.command.build_scripts import build_scripts
from distutils.sysconfig import get_python_inc
+from distutils.extension import Extension
from distutils.core import setup
-import glob
-import os
-import sys
-from dsextras import get_m4_define, getoutput, have_pkgconfig, \
- GLOBAL_INC, GLOBAL_MACROS, InstallLib, InstallData, BuildExt, \
- PkgConfigExtension, TemplateExtension, \
- pkgc_get_libraries, pkgc_get_library_dirs, pkgc_get_include_dirs
+from dsextras import GLOBAL_MACROS, GLOBAL_INC, get_m4_define, getoutput, \
+ have_pkgconfig, pkgc_get_libraries, \
+ pkgc_get_library_dirs, pkgc_get_include_dirs, \
+ PkgConfigExtension, TemplateExtension, \
+ BuildExt, InstallLib, InstallData
if '--yes-i-know-its-not-supported' in sys.argv:
sys.argv.remove('--yes-i-know-its-not-supported')