summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorChristoph Reiter <reiter.christoph@gmail.com>2018-03-25 16:19:41 +0200
committerChristoph Reiter <reiter.christoph@gmail.com>2018-03-25 16:19:41 +0200
commit560b9efbb3c93fa4e6ca31d10c77d88ab11c409a (patch)
tree32827aefe60cf190c183453ea7cd371c164a04d0 /setup.py
parentbe895cafdb7197c92f428a40b4599f9af38cde28 (diff)
downloadpygobject-560b9efbb3c93fa4e6ca31d10c77d88ab11c409a.tar.gz
setup.py: add -s option for the test command to not capture output
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py6
1 files changed, 6 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 1b503bd0..e894bbf6 100755
--- a/setup.py
+++ b/setup.py
@@ -543,18 +543,21 @@ class test(Command):
("valgrind", None, "run tests under valgrind"),
("valgrind-log-file=", None, "save logs instead of printing them"),
("gdb", None, "run tests under gdb"),
+ ("no-capture", "s", "don't capture test output"),
]
def initialize_options(self):
self.valgrind = None
self.valgrind_log_file = None
self.gdb = None
+ self.no_capture = None
def finalize_options(self):
self.valgrind = bool(self.valgrind)
if self.valgrind_log_file and not self.valgrind:
raise DistutilsOptionError("valgrind not enabled")
self.gdb = bool(self.gdb)
+ self.no_capture = bool(self.no_capture)
def run(self):
cmd = self.reinitialize_command("build_tests")
@@ -564,6 +567,9 @@ class test(Command):
env = os.environ.copy()
env.pop("MSYSTEM", None)
+ if self.no_capture:
+ env["PYGI_TEST_VERBOSE"] = "1"
+
env["MALLOC_PERTURB_"] = "85"
env["MALLOC_CHECK_"] = "3"
env["G_SLICE"] = "debug-blocks"