summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorChristoph Reiter <reiter.christoph@gmail.com>2018-04-05 11:30:44 +0200
committerChristoph Reiter <reiter.christoph@gmail.com>2018-04-05 11:30:44 +0200
commit5f961b426b9bd25956e5364770c71c34c414d4e6 (patch)
tree0328b383b91ba4be1e22e3f636bcd689cee0573d /setup.py
parent8b55a207cdb8a1ec5c1cdcce48f69d292192f9b7 (diff)
downloadpygobject-5f961b426b9bd25956e5364770c71c34c414d4e6.tar.gz
build: use -Wconversion -Wno-sign-conversion. Fixes #191
In some cases changing the type used was enough, in some others I just force casted things as too many changes would be required and overflow unlikely (for array marshalling the cache uses gssize while the marshalling code uses garray and thus guint) My hope is that having this enabled will improve things gradually with future cleanups.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 52af46f2..1ef7b90a 100755
--- a/setup.py
+++ b/setup.py
@@ -799,6 +799,7 @@ def add_ext_compiler_flags(ext, compiler, _cache={}):
"-Wundef",
"-Wunused-but-set-variable",
"-Wwrite-strings",
+ "-Wconversion",
]
args += [
@@ -806,6 +807,7 @@ def add_ext_compiler_flags(ext, compiler, _cache={}):
"-Wno-missing-field-initializers",
"-Wno-unused-parameter",
"-Wno-discarded-qualifiers",
+ "-Wno-sign-conversion",
]
# silence clang for unused gcc CFLAGS added by Debian