summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorDan HorĂ¡k <dan@danny.cz>2018-09-14 07:16:39 -0400
committerChristoph Reiter <reiter.christoph@gmail.com>2018-09-14 16:06:35 +0200
commitaa6dc30a1eb25eea9587f8e96dad3caa12d02e37 (patch)
tree34b03e93671951525563af59f17bb26442997cb8 /setup.py
parent708160a7d6ecda9aab9a51d433443afcf100e2d7 (diff)
downloadpygobject-aa6dc30a1eb25eea9587f8e96dad3caa12d02e37.tar.gz
revert closure typecasts from commit 25a5b066 See #247
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index eb3b5de8..b8e91b01 100755
--- a/setup.py
+++ b/setup.py
@@ -914,7 +914,6 @@ def add_ext_compiler_flags(ext, compiler, _cache={}):
"-Wundef",
"-Wunused-but-set-variable",
"-Wwrite-strings",
- "-Wconversion",
]
if sys.version_info[:2] != (3, 4):
@@ -929,6 +928,7 @@ def add_ext_compiler_flags(ext, compiler, _cache={}):
"-Wno-discarded-qualifiers",
"-Wno-sign-conversion",
"-Wno-cast-function-type",
+ "-Wno-int-conversion",
]
# silence clang for unused gcc CFLAGS added by Debian