summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJohan Dahlin <zilch@src.gnome.org>2004-03-27 17:13:42 +0000
committerJohan Dahlin <zilch@src.gnome.org>2004-03-27 17:13:42 +0000
commit7a6abe2198f3a908e7b50cba61a23e41ed938194 (patch)
tree3af48faf8b3e649b6701f39aea1e75d2ac69cdbe /setup.py
parent4f54a8cb614ce81c0703b972fa7eef11e9c3300f (diff)
downloadpygtk-7a6abe2198f3a908e7b50cba61a23e41ed938194.tar.gz
Removed installation of libglade and libxml2 DLLs on win32 (these are now
* setup.py: Removed installation of libglade and libxml2 DLLs on win32 (these are now part of the dropline installer). patch by Cedric Gustin, fixed bug 136731
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py13
1 files changed, 0 insertions, 13 deletions
diff --git a/setup.py b/setup.py
index aefc3117..b5a7d004 100755
--- a/setup.py
+++ b/setup.py
@@ -4,7 +4,6 @@
#
# TODO:
# pygtk.spec(.in)
-# win32 testing
# install *.pyc for codegen
#
"""Python Bindings for the GTK Widget Set.
@@ -204,18 +203,6 @@ if libglade.can_build():
ext_modules.append(libglade)
data_files.append((DEFS_DIR, ('gtk/libglade.defs',)))
- if sys.platform == 'win32':
- # We suppose the libglade and xml DLLs are somewhere in the PATH
- dlls = []
- for path in os.environ['PATH'].split(";"):
- dlls += glob.glob(os.path.normpath(
- os.path.join(path,"libglade*.dll")))
- dlls += glob.glob(os.path.normpath(
- os.path.join(path,"libxml2*.dll")))
- # We want to install those DLLs in (guess what ?) the DLLs python
- # directory
- data_files.append(("DLLs", dlls))
-
if '--enable-threading' in sys.argv:
try:
import thread