diff options
author | Fedor Brunner <fedor.brunner@azet.sk> | 2014-03-28 13:18:38 +0100 |
---|---|---|
committer | Fedor Brunner <fedor.brunner@azet.sk> | 2014-03-28 13:18:38 +0100 |
commit | 416f4a1d5cfd3c76736ebd68f33c4f76af27568b (patch) | |
tree | 40322a66f62148cc6d1f5cea8ed46db73390d202 /setup.py | |
parent | 5747b93d4c6eee7551fcff5e879c3e281f052036 (diff) | |
download | pyopenssl-git-416f4a1d5cfd3c76736ebd68f33c4f76af27568b.tar.gz |
Added dependency for cryptography>=0.3.
Test split into multiple methods.
Added changelog entry.
If you use these methods to
implement TLS channel binding (RFC 5929) disable session
resumption because triple handshake attacks against TLS.
https://www.ietf.org/mail-archive/web/tls/current/msg11337.html
https://secure-resumption.com/tlsauth.pdf
Diffstat (limited to 'setup.py')
-rwxr-xr-x | setup.py | 2 |
1 files changed, 1 insertions, 1 deletions
@@ -34,7 +34,7 @@ setup(name='pyOpenSSL', version=__version__, maintainer_email = 'exarkun@twistedmatrix.com', url = 'https://github.com/pyca/pyopenssl', license = 'APL2', - install_requires=["cryptography>=0.2.1", "six>=1.5.2"], + install_requires=["cryptography>=0.3", "six>=1.5.2"], long_description = """\ High-level wrapper around a subset of the OpenSSL library, includes * SSL.Connection objects, wrapping the methods of Python's portable |