summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorNed Batchelder <ned@nedbatchelder.com>2022-12-27 10:55:17 -0500
committerNed Batchelder <ned@nedbatchelder.com>2022-12-27 10:55:17 -0500
commit9b4c05dbc779a47c5b65e9a6ceebe032cf96b944 (patch)
tree51b374d3aa9babb4b0fac68102beb1f1870e8b26 /pyproject.toml
parent00f681d6a63c66740a2a93ee138f351b531430b0 (diff)
downloadpython-coveragepy-git-9b4c05dbc779a47c5b65e9a6ceebe032cf96b944.tar.gz
test: add type annotations for files.py
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml4
1 files changed, 2 insertions, 2 deletions
diff --git a/pyproject.toml b/pyproject.toml
index a9c7db12..e3acd9c1 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -8,10 +8,10 @@ build-backend = 'setuptools.build_meta'
[tool.mypy]
# mypy settings started from https://quantlane.com/blog/type-checking-large-codebase/
# Ensure full coverage
-disallow_untyped_calls = true
+disallow_untyped_calls = false
disallow_untyped_defs = true
disallow_incomplete_defs = true
-disallow_untyped_decorators = true
+disallow_untyped_decorators = false
check_untyped_defs = true
# Restrict dynamic typing