summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorNed Batchelder <ned@nedbatchelder.com>2023-01-12 21:02:54 -0500
committerNed Batchelder <ned@nedbatchelder.com>2023-01-12 21:04:26 -0500
commitb059a67fd1fe5d514f7c283f5ab99052e1cea15f (patch)
treec2f80b395589ecc83daf189b5b8a2fd54b3ee97a /pyproject.toml
parent2be37e3d695af882ccedd71168f82ffd12bca961 (diff)
downloadpython-coveragepy-git-b059a67fd1fe5d514f7c283f5ab99052e1cea15f.tar.gz
mypy: turn on disallow_untyped_decorators
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml3
1 files changed, 1 insertions, 2 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 4f2b5936..b21ba3b7 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -6,13 +6,12 @@ requires = ['setuptools']
build-backend = 'setuptools.build_meta'
[tool.mypy]
-# mypy settings started from https://quantlane.com/blog/type-checking-large-codebase/
check_untyped_defs = true
disallow_any_generics = true
disallow_incomplete_defs = true
disallow_subclassing_any = true
disallow_untyped_calls = true
-disallow_untyped_decorators = false
+disallow_untyped_decorators = true
disallow_untyped_defs = true
follow_imports = "silent"
ignore_missing_imports = true