summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorThomas Grainger <tagrain@gmail.com>2021-07-13 11:23:09 +0100
committerGitHub <noreply@github.com>2021-07-13 03:23:09 -0700
commit80bfea74c10dec30a0fa64e1379b80c897b060a9 (patch)
treec2ee11fb7e506c147c20f48619f3c4cb197ef11f /setup.py
parent8cb321599e1c738c1e2af8f009a40e35423bcd9f (diff)
downloadpython-coveragepy-git-80bfea74c10dec30a0fa64e1379b80c897b060a9.tar.gz
Support TOML v1.0.0 syntax in `pyproject.toml` (#1186)
* Support TOML v1.0.0 syntax in `pyproject.toml` fixes #1180 Co-authored-by: Taneli Hukkinen <3275109+hukkin@users.noreply.github.com> * fix toml meta test * use pytest.mark.parametrize to narrow test failure * Update tests/test_config.py Co-authored-by: Taneli Hukkinen <3275109+hukkin@users.noreply.github.com> Co-authored-by: Taneli Hukkinen <3275109+hukkin@users.noreply.github.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index da2df88f..f6fb7b4e 100644
--- a/setup.py
+++ b/setup.py
@@ -107,7 +107,7 @@ setup_args = dict(
extras_require={
# Enable pyproject.toml support.
- 'toml': ['toml'],
+ 'toml': ['tomli'],
},
# We need to get HTML assets from our htmlfiles directory.