diff options
author | Ned Batchelder <ned@nedbatchelder.com> | 2016-12-17 14:08:19 -0500 |
---|---|---|
committer | Ned Batchelder <ned@nedbatchelder.com> | 2016-12-17 14:08:19 -0500 |
commit | c157e2bf788c288e8d3c5364605326ead948a7ac (patch) | |
tree | 89d0bcbf5dc3f87d2ba91f64e4b53d2b975d96d3 /setup.py | |
parent | 6e199c74e9d06ce6720f87c383f8fd92fc329844 (diff) | |
download | python-coveragepy-git-c157e2bf788c288e8d3c5364605326ead948a7ac.tar.gz |
Put a count of contributors into the authors string
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 7 |
1 files changed, 6 insertions, 1 deletions
@@ -46,6 +46,11 @@ with open(cov_ver_py) as version_file: with open("README.rst") as readme: long_description = readme.read().replace("http://coverage.readthedocs.io", __url__) +with open("CONTRIBUTORS.txt") as contributors: + paras = contributors.read().split("\n\n") + num_others = len(paras[-1].splitlines()) + num_others += 1 # Count Gareth Rees, who is mentioned in the top paragraph. + classifier_list = classifiers.splitlines() if version_info[3] == 'alpha': @@ -86,7 +91,7 @@ setup_args = dict( # We need to get HTML assets from our htmlfiles directory. zip_safe=False, - author='Ned Batchelder and others', + author='Ned Batchelder and {0} others'.format(num_others), author_email='ned@nedbatchelder.com', description=doc, long_description=long_description, |