summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorNed Batchelder <ned@nedbatchelder.com>2018-09-13 09:42:26 -0400
committerNed Batchelder <ned@nedbatchelder.com>2018-09-13 09:42:26 -0400
commit189504112784fbafc68ee0757754e8806573d279 (patch)
treefb18607b44e8fb3b68789e5ac80a67a5c570e369 /setup.py
parent42c0c58c452f6f10b26986cefe9cd00688081546 (diff)
downloadpython-coveragepy-git-189504112784fbafc68ee0757754e8806573d279.tar.gz
Check for import order
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 5 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index accfd18f..af99b59b 100644
--- a/setup.py
+++ b/setup.py
@@ -9,10 +9,12 @@
import os
import sys
+# Setuptools has to be imported before distutils, or things break.
from setuptools import setup
-from distutils.core import Extension # pylint: disable=no-name-in-module, import-error
-from distutils.command.build_ext import build_ext # pylint: disable=no-name-in-module, import-error
-from distutils import errors # pylint: disable=no-name-in-module
+from distutils.core import Extension # pylint: disable=no-name-in-module, import-error, wrong-import-order
+from distutils.command.build_ext import build_ext # pylint: disable=no-name-in-module, import-error, wrong-import-order
+from distutils import errors # pylint: disable=no-name-in-module, wrong-import-order
+
# Get or massage our metadata. We exec coverage/version.py so we can avoid
# importing the product code into setup.py.