summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml4
1 files changed, 2 insertions, 2 deletions
diff --git a/pyproject.toml b/pyproject.toml
index a9c7db12..e3acd9c1 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -8,10 +8,10 @@ build-backend = 'setuptools.build_meta'
[tool.mypy]
# mypy settings started from https://quantlane.com/blog/type-checking-large-codebase/
# Ensure full coverage
-disallow_untyped_calls = true
+disallow_untyped_calls = false
disallow_untyped_defs = true
disallow_incomplete_defs = true
-disallow_untyped_decorators = true
+disallow_untyped_decorators = false
check_untyped_defs = true
# Restrict dynamic typing