summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorNed Batchelder <ned@nedbatchelder.com>2012-11-17 09:53:31 -0500
committerNed Batchelder <ned@nedbatchelder.com>2012-11-17 09:53:31 -0500
commit5fd16f1d8d886fdfeb687c307fcec5dda5adba77 (patch)
tree2d93f241aef732c2d2eb8be793afac2f1bc9f05a /setup.py
parent0cf4661becd020f93c76907b2d6ca3263b4065ae (diff)
downloadpython-coveragepy-5fd16f1d8d886fdfeb687c307fcec5dda5adba77.tar.gz
No longer try to bootstrap setuptools. It is a pre-req. Closes #202
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py10
1 files changed, 0 insertions, 10 deletions
diff --git a/setup.py b/setup.py
index 69a60a8..088a300 100644
--- a/setup.py
+++ b/setup.py
@@ -37,16 +37,6 @@ Topic :: Software Development :: Testing
# Pull in the tools we need.
import os, sys
-# Distribute is a new fork of setuptools. It's supported on Py3.x, so we use
-# it there, but stick with classic setuptools on Py2.x until Distribute becomes
-# more accepted.
-if sys.version_info >= (3, 0):
- from distribute_setup import use_setuptools
-else:
- from ez_setup import use_setuptools
-
-use_setuptools()
-
from setuptools import setup
from distutils.core import Extension # pylint: disable=E0611,F0401