summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorNed Batchelder <ned@nedbatchelder.com>2016-12-27 20:03:35 -0500
committerNed Batchelder <ned@nedbatchelder.com>2016-12-27 20:03:35 -0500
commit1eeb1037b2cb04e79be33452f8b31a9b5dca4406 (patch)
treee4c1ef0d3c272fb146909eef74b355e91a88c52c /setup.py
parent5081f861d06108fe1c6419f05042573ccd4e9eed (diff)
downloadpython-coveragepy-1eeb1037b2cb04e79be33452f8b31a9b5dca4406.tar.gz
Fix installation in ascii-default environments. #540
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 0e89306..282439f 100644
--- a/setup.py
+++ b/setup.py
@@ -46,8 +46,8 @@ with open(cov_ver_py) as version_file:
with open("README.rst") as readme:
long_description = readme.read().replace("http://coverage.readthedocs.io", __url__)
-with open("CONTRIBUTORS.txt") as contributors:
- paras = contributors.read().split("\n\n")
+with open("CONTRIBUTORS.txt", "rb") as contributors:
+ paras = contributors.read().split(b"\n\n")
num_others = len(paras[-1].splitlines())
num_others += 1 # Count Gareth Rees, who is mentioned in the top paragraph.