summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorNed Batchelder <ned@nedbatchelder.com>2015-08-30 10:52:06 -0400
committerNed Batchelder <ned@nedbatchelder.com>2015-08-30 10:52:06 -0400
commit848e8cbb2ea046680d6a539d8a7b6a7e214cf8a9 (patch)
tree3c039a93d72efcdff986df5d3271d670d38c9343 /setup.py
parent1aa10c077e3ca7b9c7f63cc64da0cc84be89c8ba (diff)
downloadpython-coveragepy-848e8cbb2ea046680d6a539d8a7b6a7e214cf8a9.tar.gz
Fix pylint issue.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 5 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 47334fd..a2e4acf 100644
--- a/setup.py
+++ b/setup.py
@@ -30,8 +30,11 @@ Topic :: Software Development :: Testing
cov_ver_py = os.path.join(os.path.split(__file__)[0], "coverage/version.py")
with open(cov_ver_py) as version_file:
- doc = __doc__ # __doc__ will be overwritten by version.py.
- __version__ = __url__ = version = "" # Keep pylint happy.
+ # __doc__ will be overwritten by version.py.
+ doc = __doc__
+ # Keep pylint happy.
+ __version__ = __url__ = version_info = ""
+ # Execute the code in version.py.
exec(compile(version_file.read(), cov_ver_py, 'exec'))
with open("README.rst") as readme: