diff options
author | Chuck Short <chuck.short@canonical.com> | 2012-04-30 08:50:02 -0400 |
---|---|---|
committer | Chuck Short <chuck.short@canonical.com> | 2012-04-30 11:21:12 -0400 |
commit | 93c1755acdaa6166ab0d6e27f89673a9a0b4e5ee (patch) | |
tree | 70a7061d73c9c0fe04abfc64b2a935829157d3a0 /setup.py | |
parent | ae58edcba737a78fcae299e0bf76e30ba5492e60 (diff) | |
download | python-glanceclient-93c1755acdaa6166ab0d6e27f89673a9a0b4e5ee.tar.gz |
Added condition requirement to simplejson
simplejson is a part of python 2.6.
Change-Id: I3a1d776918c8707f21532fe3b043a039b72d6704
Signed-off-by: Chuck Short <chuck.short@canonical.com>
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 4 |
1 files changed, 4 insertions, 0 deletions
@@ -1,4 +1,5 @@ import os +import sys import setuptools @@ -11,6 +12,9 @@ requires = parse_requirements() dependency_links = parse_dependency_links() write_git_changelog() +if sys.version_info < (2, 6): + requires.append('simplejson') + def read(fname): return open(os.path.join(os.path.dirname(__file__), fname)).read() |