summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorWaylan Limberg <waylan.limberg@icloud.com>2020-10-06 13:23:32 -0400
committerGitHub <noreply@github.com>2020-10-06 13:23:32 -0400
commitf4b936b4125719a6bcc7c7859e08b2da720892de (patch)
tree2b98e14f3ece5e4b3ad39c29749ce5d00973700d /setup.py
parent2e0962ef1412b0cd566331954aff82711ce93acf (diff)
downloadpython-markdown-f4b936b4125719a6bcc7c7859e08b2da720892de.tar.gz
Add PY39 support and drop PY35 (#1026)
Python 3.5 reached end-of-life on 2020-09-12 and Python 3.9 was released on 2020-10-05.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 1f478ca..2e0ce18 100755
--- a/setup.py
+++ b/setup.py
@@ -74,7 +74,7 @@ setup(
maintainer_email='waylan.limberg@icloud.com',
license='BSD License',
packages=['markdown', 'markdown.extensions'],
- python_requires='>=3.5',
+ python_requires='>=3.6',
install_requires=["importlib-metadata;python_version<'3.8'"],
extras_require={
'testing': [
@@ -114,10 +114,10 @@ setup(
'Operating System :: OS Independent',
'Programming Language :: Python',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: 3.8',
+ 'Programming Language :: Python :: 3.9',
'Programming Language :: Python :: 3 :: Only',
'Programming Language :: Python :: Implementation :: CPython',
'Programming Language :: Python :: Implementation :: PyPy',