summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Stinner <victor.stinner@gmail.com>2014-11-21 13:54:59 +0100
committerVictor Stinner <victor.stinner@gmail.com>2014-11-21 13:54:59 +0100
commit174c1f64eb0ec9b3afcdcf76197d17985618fb64 (patch)
treef9284641a36151861d57927cca61a4f7adcacbf6
parent499a82fb08d1c493113e2004e332ee81339f1e27 (diff)
downloadaioeventlet-174c1f64eb0ec9b3afcdcf76197d17985618fb64.tar.gz
TODO
-rw-r--r--doc/status.rst12
-rw-r--r--setup.py4
2 files changed, 13 insertions, 3 deletions
diff --git a/doc/status.rst b/doc/status.rst
index 329b329..7b0802d 100644
--- a/doc/status.rst
+++ b/doc/status.rst
@@ -4,7 +4,17 @@ To do
* wrap_greenthread() must not log the exception to sys.stderr if the
greenthread didn't start
* register signals in eventlet hub, only needed for pyevent hub?
-* write tests for: pipes, signals and subprocesses
+* port greenio examples to aiogreen
+* write unit tests for, and maybe also examples for:
+
+ - wait_greenthread() + spawn_n
+ - TCP server
+ - UDP socket
+ - UNIX socket
+ - pipes
+ - signals
+ - subprocesses
+
* run an event loop in a thread different than the main thread
* tox.ini: test Python 3.3 with monkey-patching, see eventlet bug:
https://github.com/eventlet/eventlet/pull/168
diff --git a/setup.py b/setup.py
index 2946028..9593748 100644
--- a/setup.py
+++ b/setup.py
@@ -6,7 +6,7 @@
# \Python27\python.exe runtest.py -r
# \Python27\python.exe runtest.py -r -m
#
-# - update the version in setup.py to X.Y
+# - update the version in setup.py and doc/conf.py to X.Y
# - set release date in README
# - check that "python setup.py sdist" contains all files tracked by
# the SCM (Mercurial), or update MANIFEST.in
@@ -14,7 +14,7 @@
# - hg tag X.Y
# - hg push
# - python setup.py sdist bdist_wheel register upload
-# - increment version in setup.py
+# - increment version in setup.py and doc/conf.py
# - hg ci && hg push
import os