summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Stinner <victor.stinner@gmail.com>2014-11-21 13:53:15 +0100
committerVictor Stinner <victor.stinner@gmail.com>2014-11-21 13:53:15 +0100
commit499a82fb08d1c493113e2004e332ee81339f1e27 (patch)
tree1a2b44e4defc5222cdda5b7562649f2c0ca64508
parent4a0496fb5b9c95a1d265fcb64e94c25c4f877c51 (diff)
downloadaioeventlet-499a82fb08d1c493113e2004e332ee81339f1e27.tar.gz
documentation; update URL in setup.py
-rw-r--r--doc/changelog.rst10
-rw-r--r--doc/status.rst33
-rw-r--r--doc/using.rst4
-rw-r--r--setup.py2
4 files changed, 15 insertions, 34 deletions
diff --git a/doc/changelog.rst b/doc/changelog.rst
index 1f4f9f1..10b2836 100644
--- a/doc/changelog.rst
+++ b/doc/changelog.rst
@@ -4,10 +4,12 @@ Changelog
Version 0.2 (development version)
---------------------------------
-The core of the event loop was rewritten to fits better in asyncio and
-eventlet. aiogreen now reuses more code from asyncio/trollius. The code
-handling file descriptors was also fixed to respect asyncio contract:
-only call the callback once per loop iteration.
+aiogreen event loop has been rewritten to reuse more asyncio/trollius code. It
+now only has a few specific code.
+
+All asyncio network are supported: TCP, UCP and UNIX clients and servers.
+
+Support of pipes, signal handlers and subprocess is still experimental.
Changes:
diff --git a/doc/status.rst b/doc/status.rst
index e098b9f..329b329 100644
--- a/doc/status.rst
+++ b/doc/status.rst
@@ -1,36 +1,11 @@
-Implemented
-===========
-
-Methods:
-
-* call_at()
-* call_later()
-* call_soon()
-* run_forever()
-* run_in_executor()
-* run_until_complete()
-* create_connection(): TCP client
-* stop()
-* coroutines and tasks
-
-aiogreen 0.1 was tested:
-
-* on Python 2.7, 3.3 and 3.5
-* on Linux and Windows
-* with Trollius 1.0, 1.0.1 and 1.0.2
-* with asyncio 0.4.1 and 3.4.2
-
-
-To do (Not supported)
-=====================
+To do
+=====
* wrap_greenthread() must not log the exception to sys.stderr if the
greenthread didn't start
+* register signals in eventlet hub, only needed for pyevent hub?
+* write tests for: pipes, signals and subprocesses
* run an event loop in a thread different than the main thread
-* sockets: create_server, sock_recv
-* pipes: connect_read_pipe
-* subprocesses: need pipes
-* signal handlers: add_signal_handler (only for pyevent hub?)
* tox.ini: test Python 3.3 with monkey-patching, see eventlet bug:
https://github.com/eventlet/eventlet/pull/168
diff --git a/doc/using.rst b/doc/using.rst
index f42f0e3..1783b69 100644
--- a/doc/using.rst
+++ b/doc/using.rst
@@ -84,6 +84,10 @@ API
aiogreen specific functions:
+.. warning::
+ aiogreen API is not stable yet. Function names may change in future
+ releases, functions may change completly or even be removed.
+
.. function:: link_future(future)
Wait for a future (or a task) from a greenthread.
diff --git a/setup.py b/setup.py
index 5f24c39..2946028 100644
--- a/setup.py
+++ b/setup.py
@@ -51,7 +51,7 @@ install_options = {
"description": "asyncio event loop scheduling callbacks in eventlet.",
"long_description": long_description,
- "url": "https://bitbucket.org/haypo/aiogreen/",
+ "url": "http://aiogreen.readthedocs.org/",
"classifiers": [
"Programming Language :: Python",