summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authoraodag <none@none>2012-02-03 23:25:27 +0900
committeraodag <none@none>2012-02-03 23:25:27 +0900
commit2140189f867ef5c41f754c4ed289c6c8ba0521b3 (patch)
treef1fba197092b63196de510982830942b9df2063d
parent7658265ab5fff4a0ba7f28fda36fa6658d4bf6f1 (diff)
downloadalembic-2140189f867ef5c41f754c4ed289c6c8ba0521b3.tar.gz
fix for unneccesary require to argparse
-rw-r--r--setup.py18
1 files changed, 10 insertions, 8 deletions
diff --git a/setup.py b/setup.py
index 298b2fb..bab381b 100644
--- a/setup.py
+++ b/setup.py
@@ -15,6 +15,15 @@ v.close()
readme = os.path.join(os.path.dirname(__file__), 'README.rst')
+requires = [
+ 'SQLAlchemy>=0.6.0',
+ 'Mako',
+]
+
+try:
+ import argparse
+except ImportError:
+ requires.append('argparse')
setup(name='alembic',
version=VERSION,
@@ -40,14 +49,7 @@ setup(name='alembic',
tests_require = ['nose >= 0.11'],
test_suite = "nose.collector",
zip_safe=False,
- install_requires=[
- 'SQLAlchemy>=0.6.0',
- 'Mako',
- # TODO: should this not be here if the env. is
- # Python 2.7/3.2 ? not sure how this is supposed
- # to be handled
- 'argparse'
- ],
+ install_requires=requires,
entry_points = {
'console_scripts': [ 'alembic = alembic.config:main' ],
},