summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authormike bayer <mike_mp@zzzcomputing.com>2018-06-29 21:09:04 -0400
committerGerrit Code Review <gerrit@ci.zzzcomputing.com>2018-06-29 21:09:04 -0400
commit07a6b7dd6df07be617afd5675c9a838ac10df4c8 (patch)
treeba93fd845cdf5e8f06a09118f8d1b490b1d24095 /setup.py
parentd06857c136039264bf8f0d508655f648aa51b355 (diff)
parent843decd8ea0e7785914ed563ba93590e9fda399b (diff)
downloadalembic-07a6b7dd6df07be617afd5675c9a838ac10df4c8.tar.gz
Merge "Drop Python 2.6 / 3.3 support"
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py11
1 files changed, 6 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index 6795829..3628916 100644
--- a/setup.py
+++ b/setup.py
@@ -19,11 +19,6 @@ requires = [
'python-dateutil'
]
-try:
- import argparse
-except ImportError:
- requires.append('argparse')
-
class PyTest(TestCommand):
user_options = [('pytest-args=', 'a', "Arguments to pass to py.test")]
@@ -48,12 +43,18 @@ setup(name='alembic',
version=VERSION,
description="A database migration tool for SQLAlchemy.",
long_description=open(readme).read(),
+ python_requires='>=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*',
classifiers=[
'Development Status :: 5 - Stable',
'Environment :: Console',
'Intended Audience :: Developers',
'Programming Language :: Python',
+ 'Programming Language :: Python :: 2',
+ 'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3.4',
+ 'Programming Language :: Python :: 3.5',
+ 'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: Implementation :: CPython',
'Programming Language :: Python :: Implementation :: PyPy',
'Topic :: Database :: Front-Ends',