summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 7c582f6..bda95e3 100644
--- a/setup.py
+++ b/setup.py
@@ -1,4 +1,5 @@
#!/usr/bin/env python
+from io import open
import os
# appdirs is a dependency of setuptools, so allow installing without it.
try:
@@ -9,7 +10,7 @@ import ast
def read(fname):
- inf = open(os.path.join(os.path.dirname(__file__), fname))
+ inf = open(os.path.join(os.path.dirname(__file__), fname), encoding='utf8')
out = "\n" + inf.read().replace("\r\n", "\n")
inf.close()
return out