summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Grönholm <alex.gronholm@nextday.fi>2017-11-07 01:30:48 +0200
committerAlex Grönholm <alex.gronholm@nextday.fi>2017-11-07 01:31:30 +0200
commit64482a782cb8c32f6658a8bd93ece90b55cf05e2 (patch)
treefc12f981c4ac2c10c735b4486953eddf29c99d49
parentad71be4d18eec9db69dfd4d7813573766fc6d393 (diff)
downloadapscheduler-64482a782cb8c32f6658a8bd93ece90b55cf05e2.tar.gz
Fixed syntax highlighting and indentation issues
-rw-r--r--docs/extending.rst25
1 files changed, 10 insertions, 15 deletions
diff --git a/docs/extending.rst b/docs/extending.rst
index 111f047..a6fd590 100644
--- a/docs/extending.rst
+++ b/docs/extending.rst
@@ -28,13 +28,11 @@ You can also register it as a plugin so you can use can use the alternate form o
scheduler.add_job(target, 'my_trigger', arg1='foo')
-This is done by adding an entry point in your project's :file:`setup.py`:
-
-.. code-block:: ini
+This is done by adding an entry point in your project's :file:`setup.py`::
...
entry_points={
- 'apscheduler.triggers': ['my_trigger = mytoppackage.subpackage:MyTrigger']
+ 'apscheduler.triggers': ['my_trigger = mytoppackage.subpackage:MyTrigger']
}
@@ -65,9 +63,7 @@ You can also register it as a plugin so you can use can use the alternate form o
scheduler.add_jobstore('my_jobstore', 'mystore')
-This is done by adding an entry point in your project's :file:`setup.py`:
-
-.. code-block:: ini
+This is done by adding an entry point in your project's :file:`setup.py`::
...
entry_points={
@@ -84,11 +80,12 @@ nodes.
Start by subclassing :class:`~apscheduler.executors.base.BaseExecutor`.
The responsibilities of an executor are as follows:
- * Performing any initialization when ``start()`` is called
- * Releasing any resources when ``shutdown()`` is called
- * Keeping track of the number of instances of each job running on it, and refusing to run more
- than the maximum
- * Notifying the scheduler of the results of the job
+
+* Performing any initialization when ``start()`` is called
+* Releasing any resources when ``shutdown()`` is called
+* Keeping track of the number of instances of each job running on it, and refusing to run more
+ than the maximum
+* Notifying the scheduler of the results of the job
If your executor needs to serialize the jobs, make sure you either use pickle for it, or invoke the
``__getstate__`` and ``__setstate__`` special methods to respectively get and set the Job state.
@@ -104,9 +101,7 @@ You can also register it as a plugin so you can use can use the alternate form o
scheduler.add_executor('my_executor', 'myexecutor')
-This is done by adding an entry point in your project's :file:`setup.py`:
-
-.. code-block:: ini
+This is done by adding an entry point in your project's :file:`setup.py`::
...
entry_points={