summaryrefslogtreecommitdiff
path: root/README
diff options
context:
space:
mode:
authorDavid Douard <david.douard@logilab.fr>2013-06-17 18:09:03 +0200
committerDavid Douard <david.douard@logilab.fr>2013-06-17 18:09:03 +0200
commitde948487c55093839c6c022bff5f45b195637c3d (patch)
treeea29aee5cf6a39fd566a2a5008bef682813d5a39 /README
parent71454b097693d33daceb5d83925abfc62c9e12ec (diff)
downloadastroid-de948487c55093839c6c022bff5f45b195637c3d.tar.gz
rename the project astroid
Diffstat (limited to 'README')
-rw-r--r--README40
1 files changed, 21 insertions, 19 deletions
diff --git a/README b/README
index db8dca1..426fbd7 100644
--- a/README
+++ b/README
@@ -1,47 +1,49 @@
-ASTNG
-=====
+Astroid
+=======
-What's this ?
--------------
+What's this?
+------------
The aim of this module is to provide a common base representation of
python source code for projects such as pychecker, pyreverse,
pylint... Well, actually the development of this library is essentially
-governed by pylint's needs.
+governed by pylint's needs. It used to be called logilab-astng.
-It provides a compatible representation which comes from the `_ast` module.
-It rebuilds the tree generated by the builtin _ast module by recursively
-walking down the AST and building an extended ast (let's call it astng ;). The
-new node classes have additional methods and attributes for different usages.
-They include some support for static inference and local name scopes.
-Furthermore, astng builds partial trees by inspecting living objects.
+It provides a compatible representation which comes from the `_ast`
+module. It rebuilds the tree generated by the builtin _ast module by
+recursively walking down the AST and building an extended ast. The new
+node classes have additional methods and attributes for different
+usages. They include some support for static inference and local name
+scopes. Furthermore, astroid builds partial trees by inspecting living
+objects.
Main modules are:
* `bases`, `node_classses` and `scoped_nodes` contain the classes for the
different type of nodes of the tree.
-* the `manager` contains a high level object to get astng trees from
+* the `manager` contains a high level object to get astroid trees from
source files and living objects. It maintains a cache of previously
- constructed tree for quick access
+ constructed tree for quick access.
Installation
------------
-Extract the tarball, jump into the created directory and run ::
+Extract the tarball, jump into the created directory and run::
python setup.py install
-For installation options, see ::
+For installation options, see::
python setup.py install --help
-If you have any questions, please mail the
-python-project@lists.logilab.org mailing list for support. See
-http://lists.logilab.org/mailman/listinfo/python-projects for
-subscription information and archives.
+If you have any questions, please mail the code-quality@python.org
+mailing list for support. See
+http://mail.python.org/mailman/listinfo/code-quality for subscription
+information and archives. You may find older archives at
+http://lists.logilab.org/mailman/listinfo/python-projects .
Test
----