summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorSylvain Th?nault <sylvain.thenault@logilab.fr>2013-10-04 09:50:48 +0200
committerSylvain Th?nault <sylvain.thenault@logilab.fr>2013-10-04 09:50:48 +0200
commit3e7698a927c7de2ddab38f297211b67ad9ed7ebc (patch)
tree75895536c925bdcc79db5d7a268737db6c54a80b /setup.py
parent23d0116e46cfe7995904f15dd850cbf1be9f415e (diff)
downloadastroid-3e7698a927c7de2ddab38f297211b67ad9ed7ebc.tar.gz
backport pylint fix on setup.py for py3k windows/cross-compiliation install issue
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py12
1 files changed, 3 insertions, 9 deletions
diff --git a/setup.py b/setup.py
index f8b8337..a654be1 100644
--- a/setup.py
+++ b/setup.py
@@ -132,21 +132,15 @@ class MyBuildPy(build_py):
else:
base = modname
basedir = os.path.join(self.build_lib, base)
- if sys.platform == 'win32':
- two_to_three = [sys.executable]
- exe_path = os.path.dirname(sys.executable)
- two_to_three.append(os.path.join(exe_path, 'Tools\\Scripts\\2to3.py'))
- else:
- two_to_three = ['2to3']
for directory in include_dirs:
dest = join(basedir, directory)
shutil.rmtree(dest, ignore_errors=True)
shutil.copytree(directory, dest)
if sys.version_info >= (3, 0):
# process manually python file in include_dirs (test data)
- from subprocess import check_call
- print('running 2to3 on', dest) # parens are NOT optional here for py3k compat
- check_call(two_to_three + ['-wn', dest])
+ from distutils.util import run_2to3
+ print('running 2to3 on', dest)
+ run_2to3([dest])
def install(**kwargs):
"""setup entry point"""