summaryrefslogtreecommitdiff
path: root/.travis.yml
diff options
context:
space:
mode:
authorjquast <contact@jeffquast.com>2014-03-22 18:03:08 -0700
committerjquast <contact@jeffquast.com>2014-03-22 18:03:08 -0700
commit5fd8adc8b04ef8c2f9f55a6087a3de90eeab50b2 (patch)
tree377639b1d24e2c5a4c309b07ff66f27c84beb655 /.travis.yml
parent3de7103d8200a04553e1b941e72c6685abb6904b (diff)
downloadblessings-5fd8adc8b04ef8c2f9f55a6087a3de90eeab50b2.tar.gz
coverage only for py27; test packaged only for py3
Diffstat (limited to '.travis.yml')
-rw-r--r--.travis.yml27
1 files changed, 15 insertions, 12 deletions
diff --git a/.travis.yml b/.travis.yml
index e52def6..80a7187 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -7,23 +7,26 @@ env:
- TOXENV=pypy
install:
- # travis wants requirements.txt; we don't,
- # use only 'requires=' in setup.py, which is dynamic;
# for python versions <26, we must install ordereddict
- - if [[ $TRAVIS_PYTHON_VERSION == 2.5 ]] || [[ $TRAVIS_PYTHON_VERSION == 2.6 ]]; then pip install --use-mirrors ordereddict; fi
- - pip install -q tox coverage coveralls
+ # mimicking the same dynamically generated 'requires='
+ # in setup.py
+ - if [[ $TOXENV == "py25" ]] || [[ $TOXENV == "py26" ]]; then
+ pip install -q ordereddict
+ fi
+
+ # for python version =27, cinstall and overage, coveralls.
+ # coverage is only measured and published for one version.
+ - if [[ $TOXENV == "py27" ]]; then
+ pip install -q coverage coveralls
+ fi
script:
- - mkdir -p .tox
- - cd .tox
- - coverage erase --rcfile=$TRAVIS_BUILD_DIR/.coveragerc
- - cd $TRAVIS_BUILD_DIR
- - tox
+ - tox -e $TOXENV
after_success:
- - cd .tox
- - coverage combine --rcfile=$TRAVIS_BUILD_DIR/.coveragerc
- - coveralls --rcfile=$TRAVIS_BUILD_DIR/.coveragerc
+ - if [[ $TOXENV == "py27" ]]; then
+ coveralls
+ fi
notifications:
email: