summaryrefslogtreecommitdiff
path: root/.travis.yml
diff options
context:
space:
mode:
authorjquast <contact@jeffquast.com>2014-03-09 17:15:08 -0700
committerjquast <contact@jeffquast.com>2014-03-09 17:15:08 -0700
commitc64b3fe6d337c8985ab3c8065757936d06e55b96 (patch)
treece42e9e8924fa2119531b3aa317198b4ffba16ac /.travis.yml
parent4ca8c2ec3440ff2bbaff618a61cd9b3a132efc6a (diff)
downloadblessings-c64b3fe6d337c8985ab3c8065757936d06e55b96.tar.gz
pytest, tox, and coverage cleanup for python26->33
working around the issue of using 2to3 by testing the installed package within tox, somewhat similar to what was originally done with nose.
Diffstat (limited to '.travis.yml')
-rw-r--r--.travis.yml27
1 files changed, 14 insertions, 13 deletions
diff --git a/.travis.yml b/.travis.yml
index 7035860..202c406 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,22 +1,23 @@
language: python
-python:
- #- 2.5
- - 2.6
- - 2.7
- - 3.2
- - 3.3
- #- 3.4
- #- 3.5
- - pypy
+env:
+ - TOXENV=py26
+ - TOXENV=py27
+ - TOXENV=py33
+ # not supported ..
+ - TOXNENV=py25 # missing
+ - TOXNENV=py32 # will fail
+ - TOXNENV=py34 # missing
+ - TOXNENV=pypy # will fail
matrix:
allow_failures:
- # bugs, u'literals'
- - python: 3.2
+ - python: 3.2 # bugs, no u'literals'
+ - pypy # a few (minor) bugs ??
script:
- - python setup.py develop test
+ - tox
install:
- if [[ $TRAVIS_PYTHON_VERSION == 2.5 ]] || [[ $TRAVIS_PYTHON_VERSION == 2.6 ]]; then pip install --use-mirrors ordereddict; fi
+ # travis wants requirements.txt; we don't, use only 'requires=' in setup.py.
+ - if [[ $TRAVIS_PYTHON_VERSION == 2.5 ]] || [[ $TRAVIS_PYTHON_VERSION == 2.6 ]]; then pip install --use-mirrors ordereddict; fi