summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErik Rose <erik@mozilla.com>2011-11-13 17:49:24 -0800
committerErik Rose <erik@mozilla.com>2011-11-13 17:55:40 -0800
commitdde2719fbb0b4eb2aedd594b8261785459775d7d (patch)
tree20e3acae0fdcde6c3a971e60afd7738ee1dfba09
parentd05bb86a21f00a91179aa36ca127a9fe7a084670 (diff)
downloadblessings-dde2719fbb0b4eb2aedd594b8261785459775d7d.tar.gz
Start using tox for tests across Python versions. Make tests run in Python 2.5.
-rw-r--r--.gitignore1
-rw-r--r--README.rst2
-rw-r--r--blessings/tests.py1
-rw-r--r--setup.py2
-rw-r--r--tox.ini6
5 files changed, 10 insertions, 2 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..84d28ed
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+.tox \ No newline at end of file
diff --git a/README.rst b/README.rst
index ed43fd6..972e9b7 100644
--- a/README.rst
+++ b/README.rst
@@ -7,7 +7,7 @@ by Erik Rose
The Pitch
=========
-curses is a great library, but there are a couple situations where it doesn't
+curses is a fine library, but there are a couple situations where it doesn't
fit:
* You want to use bold, color, and maybe a little positioning without clearing
diff --git a/blessings/tests.py b/blessings/tests.py
index 751c2fb..6b0c85a 100644
--- a/blessings/tests.py
+++ b/blessings/tests.py
@@ -1,3 +1,4 @@
+from __future__ import with_statement # Make 2.5-compatible
from StringIO import StringIO
from curses import tigetstr, tparm
import sys
diff --git a/setup.py b/setup.py
index 0cdc0a0..a313f18 100644
--- a/setup.py
+++ b/setup.py
@@ -28,6 +28,6 @@ setup(
'Topic :: Software Development :: User Interfaces',
'Topic :: Terminals'
],
- keywords=['terminal', 'tty', 'curses', 'formatting'],
+ keywords=['terminal', 'tty', 'curses', 'formatting', 'color'],
**extra_setup
)
diff --git a/tox.ini b/tox.ini
new file mode 100644
index 0000000..3204750
--- /dev/null
+++ b/tox.ini
@@ -0,0 +1,6 @@
+[tox]
+envlist = py25, py26, py27
+
+[testenv]
+commands = nosetests
+deps=nose \ No newline at end of file