summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeff Quast <jquast@io.com>2015-04-09 20:19:39 -0700
committerJeff Quast <jquast@io.com>2015-04-09 20:20:05 -0700
commitac23cb15034dc85771aaee189e77f50723d7bef1 (patch)
tree2adc7fac70368c09a101400a09de10069e1841a4
parent1052f8443468c938ab74a4897fe669cbec77794c (diff)
downloadblessings-ac23cb15034dc85771aaee189e77f50723d7bef1.tar.gz
ignore pylint 'protected-access' and tools/ folder
-rw-r--r--.prospector.yaml19
1 files changed, 7 insertions, 12 deletions
diff --git a/.prospector.yaml b/.prospector.yaml
index 5d1f7d2..8303a5f 100644
--- a/.prospector.yaml
+++ b/.prospector.yaml
@@ -1,12 +1,13 @@
inherits:
- strictness_veryhigh
-ignore:
+ignore-patterns:
- (^|/)\..+
- ^docs/
# ignore tests and bin/ for the moment, their quality does not so much matter.
- ^bin/
- ^blessings/tests/
+ - ^tools/
test-warnings: true
@@ -46,22 +47,16 @@ pylint:
# no 'mark' member
ignored-classes: pytest
disable:
- # Too many lines in module
- ##- C0302
- # Used * or ** magic
- ##- W0142
- # Used builtin function 'filter'.
- # (For maintainability, one should prefer list comprehension.)
- ##- W0141
- # Use % formatting in logging functions but pass the % parameters
- ##- W1202
+ # Access to a protected member _sugar of a client class
+ - protected-access
pyroma:
# checks setup.py
run: true
vulture:
- # this tool does a good job of finding unused code.
- run: true
+ # this tool does a good job of finding unused code, which isn't terribly
+ # useful from an API perspective, disable.
+ run: false
# vim: noai:ts=4:sw=4