summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErik Rose <erik@mozilla.com>2011-11-27 14:46:09 -0800
committerErik Rose <erik@mozilla.com>2011-11-28 10:18:10 -0800
commit58ae6f5b0b1d48f2a62efa395e657f26ac802661 (patch)
treedd8e981cdf3a9080b7a5a30f4992206e3716982f
parent9baaebbecbcccffb05f836f7ab2258c2b46d7f8f (diff)
downloadblessings-58ae6f5b0b1d48f2a62efa395e657f26ac802661.tar.gz
Change license to MIT. Closes #13.
-rw-r--r--LICENSE19
-rw-r--r--README.rst11
-rw-r--r--setup.py3
3 files changed, 30 insertions, 3 deletions
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 0000000..3d3a44e
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,19 @@
+Copyright (c) 2011 Erik Rose
+
+Permission is hereby granted, free of charge, to any person obtaining a copy of
+this software and associated documentation files (the "Software"), to deal in
+the Software without restriction, including without limitation the rights to
+use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies
+of the Software, and to permit persons to whom the Software is furnished to do
+so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/README.rst b/README.rst
index e95e02a..902c4bd 100644
--- a/README.rst
+++ b/README.rst
@@ -322,13 +322,20 @@ Bugs or suggestions? Visit the `issue tracker`_.
.. _`issue tracker`: https://github.com/erikrose/blessings/issues/new
+License
+=======
+
+Blessings is under the MIT License. See the LICENSE file.
+
Version History
===============
1.2
- * Support for Python 3! We need 3.2.3 or greater, because the curses library
- couldn't decide whether to accept strs or bytes before that
+ * Added support for Python 3! We need 3.2.3 or greater, because the curses
+ library couldn't decide whether to accept strs or bytes before that
(http://bugs.python.org/issue10570).
+ * Relicensed under the MIT License.
+ * Added Sphinx docs.
1.1
* Added nicely named attributes for colors.
diff --git a/setup.py b/setup.py
index 617eb5f..25ed5af 100644
--- a/setup.py
+++ b/setup.py
@@ -14,7 +14,7 @@ setup(
long_description=open('README.rst').read(),
author='Erik Rose',
author_email='erikrose@grinchcentral.com',
- license='GPL',
+ license='MIT',
packages=find_packages(exclude=['ez_setup']),
tests_require=['Nose'],
url='https://github.com/erikrose/blessings',
@@ -24,6 +24,7 @@ setup(
'Natural Language :: English',
'Environment :: Console',
'Environment :: Console :: Curses',
+ 'License :: OSI Approved :: MIT License',
'Operating System :: POSIX',
'Programming Language :: Python :: 2',
'Programming Language :: Python :: 2.5',