summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErik Rose <erik@mozilla.com>2011-11-24 20:13:24 -0800
committerErik Rose <erik@mozilla.com>2011-11-27 11:23:40 -0800
commitfe38a088e7ea9d602ce327226ad93e977f2a30c2 (patch)
treedfadaaa9872eff826af33ec076cb8e54c3d6face
parentaf90fa34f16341620e95695da64aac0bf04cbec2 (diff)
downloadblessings-fe38a088e7ea9d602ce327226ad93e977f2a30c2.tar.gz
Remove SPOT for version, because __init__ throws a SyntaxError when imported from setup.py.
-rw-r--r--blessings/__init__.py4
-rw-r--r--docs/conf.py2
-rw-r--r--setup.py6
3 files changed, 4 insertions, 8 deletions
diff --git a/blessings/__init__.py b/blessings/__init__.py
index e83fb5c..67bbddb 100644
--- a/blessings/__init__.py
+++ b/blessings/__init__.py
@@ -6,9 +6,8 @@ try:
from io import UnsupportedOperation as IOUnsupportedOperation
except ImportError:
class IOUnsupportedOperation(Exception):
- """A dummy exception to take the place of Python 3's io.UnsupportedOperation one in Python 2"""
+ """A dummy exception to take the place of Python 3's ``io.UnsupportedOperation`` in Python 2"""
pass
-import locale
import os
from os import isatty, environ
import struct
@@ -17,7 +16,6 @@ from termios import TIOCGWINSZ
__all__ = ['Terminal']
-__version__ = (1, 1)
class Terminal(object):
diff --git a/docs/conf.py b/docs/conf.py
index a1c2f49..040b29a 100644
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -50,7 +50,7 @@ copyright = u'2011, The Mozilla Foundation'
# built documents.
#
# The short X.Y version.
-version = '.'.join(str(i) for i in blessings.__version__)
+version = '1.2'
# The full version, including alpha/beta/rc tags.
release = version
diff --git a/setup.py b/setup.py
index 4450589..617eb5f 100644
--- a/setup.py
+++ b/setup.py
@@ -2,8 +2,6 @@ import sys
from setuptools import setup, find_packages
-from blessings import __version__
-
extra_setup = {}
if sys.version_info >= (3,):
@@ -11,7 +9,7 @@ if sys.version_info >= (3,):
setup(
name='blessings',
- version='.'.join(str(i) for i in __version__),
+ version='1.2',
description='A thin, practical wrapper around terminal formatting, positioning, and more',
long_description=open('README.rst').read(),
author='Erik Rose',
@@ -37,6 +35,6 @@ setup(
'Topic :: Software Development :: User Interfaces',
'Topic :: Terminals'
],
- keywords=['terminal', 'tty', 'curses', 'formatting', 'color', 'console'],
+ keywords=['terminal', 'tty', 'curses', 'ncurses', 'formatting', 'color', 'console'],
**extra_setup
)