summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorErik Rose <erik@mozilla.com>2011-11-27 13:48:50 -0800
committerErik Rose <erik@mozilla.com>2011-11-27 13:48:50 -0800
commit9baaebbecbcccffb05f836f7ab2258c2b46d7f8f (patch)
tree445946fdca69c4c695ba019ca9261fec246fa75d /setup.py
parentaf4f0fb075053d1ced78af352c1da07e189025c9 (diff)
parent381bfb79a7476a6e958b7d08d3a80de4c4cabeac (diff)
downloadblessings-9baaebbecbcccffb05f836f7ab2258c2b46d7f8f.tar.gz
Support Python 3 >= 3.2.3.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py13
1 files changed, 9 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index bc0d3f4..617eb5f 100644
--- a/setup.py
+++ b/setup.py
@@ -2,8 +2,6 @@ import sys
from setuptools import setup, find_packages
-from blessings import __version__
-
extra_setup = {}
if sys.version_info >= (3,):
@@ -11,7 +9,7 @@ if sys.version_info >= (3,):
setup(
name='blessings',
- version='.'.join(str(i) for i in __version__),
+ version='1.2',
description='A thin, practical wrapper around terminal formatting, positioning, and more',
long_description=open('README.rst').read(),
author='Erik Rose',
@@ -25,11 +23,18 @@ setup(
'Intended Audience :: Developers',
'Natural Language :: English',
'Environment :: Console',
+ 'Environment :: Console :: Curses',
'Operating System :: POSIX',
+ 'Programming Language :: Python :: 2',
+ 'Programming Language :: Python :: 2.5',
+ 'Programming Language :: Python :: 2.6',
+ 'Programming Language :: Python :: 2.7',
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3.2',
'Topic :: Software Development :: Libraries',
'Topic :: Software Development :: User Interfaces',
'Topic :: Terminals'
],
- keywords=['terminal', 'tty', 'curses', 'formatting', 'color', 'console'],
+ keywords=['terminal', 'tty', 'curses', 'ncurses', 'formatting', 'color', 'console'],
**extra_setup
)