summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHugo <hugovk@users.noreply.github.com>2019-04-19 19:48:33 +0300
committerHugo <hugovk@users.noreply.github.com>2019-04-19 19:48:33 +0300
commitf92e54348bdc9fe3e015e73b200f61043bc11152 (patch)
tree0f4f06820b29a345ce14bcbadf646269ce783d91
parent298bafd0fd5e28093ec620efed15458626f98c9d (diff)
downloadblinker-f92e54348bdc9fe3e015e73b200f61043bc11152.tar.gz
Drop support for EOL Python 3.4
-rw-r--r--.travis.yml1
-rw-r--r--docs/source/index.rst2
-rw-r--r--setup.py3
-rw-r--r--tox.ini2
4 files changed, 3 insertions, 5 deletions
diff --git a/.travis.yml b/.travis.yml
index b9d7c68..91481c6 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,7 +1,6 @@
language: python
python:
- "2.7"
- - "3.4"
- "3.5"
- "3.6"
- "pypy"
diff --git a/docs/source/index.rst b/docs/source/index.rst
index 788eb74..bdb40ef 100644
--- a/docs/source/index.rst
+++ b/docs/source/index.rst
@@ -16,7 +16,7 @@ The core of Blinker is quite small but provides powerful features:
- thread safety
Blinker was written by Jason Kirtand and is provided under the MIT
-License. The library supports Python 2.7 and Python 3.4 or later;
+License. The library supports Python 2.7 and Python 3.5 or later;
or Jython 2.7 or later; or PyPy 2.7 or later.
diff --git a/setup.py b/setup.py
index f0a52ce..0d62b49 100644
--- a/setup.py
+++ b/setup.py
@@ -17,7 +17,7 @@ setup(name="blinker",
long_description=readme,
license='MIT License',
url='http://pythonhosted.org/blinker/',
- python_requires='>=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*',
+ python_requires='>=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*, !=3.4.*',
classifiers=[
'Development Status :: 5 - Production/Stable',
'Intended Audience :: Developers',
@@ -27,7 +27,6 @@ setup(name="blinker",
'Programming Language :: Python :: 2',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
'Topic :: Software Development :: Libraries',
diff --git a/tox.ini b/tox.ini
index fa5ce00..8f5146f 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = py27,py34,py35,py36,jython
+envlist = py27,py35,py36,jython
[testenv]
deps=nose