summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArmin Rigo <arigo@tunes.org>2016-09-06 09:49:05 +0200
committerArmin Rigo <arigo@tunes.org>2016-09-06 09:49:05 +0200
commit1b0d14005661e76d40b4b950b0d842e0457d69bf (patch)
treeb9b585ecffdb224ed04abc257266712f33692a9a
parentea2c76897db97b5dab90e7e56720f15b1a154abf (diff)
downloadcffi-1b0d14005661e76d40b4b950b0d842e0457d69bf.tar.gz
Update and document v1.8.2
-rw-r--r--c/_cffi_backend.c2
-rw-r--r--c/test_c.py2
-rw-r--r--cffi/__init__.py4
-rw-r--r--cffi/_embedding.h2
-rw-r--r--doc/source/conf.py2
-rw-r--r--doc/source/installation.rst2
-rw-r--r--doc/source/whatsnew.rst9
-rw-r--r--setup.py2
8 files changed, 17 insertions, 8 deletions
diff --git a/c/_cffi_backend.c b/c/_cffi_backend.c
index 800c448..dfe4d84 100644
--- a/c/_cffi_backend.c
+++ b/c/_cffi_backend.c
@@ -2,7 +2,7 @@
#include <Python.h>
#include "structmember.h"
-#define CFFI_VERSION "1.8.1"
+#define CFFI_VERSION "1.8.2"
#ifdef MS_WIN32
#include <windows.h>
diff --git a/c/test_c.py b/c/test_c.py
index 16407b1..d5634e5 100644
--- a/c/test_c.py
+++ b/c/test_c.py
@@ -12,7 +12,7 @@ from _cffi_backend import _testfunc, _get_types, _get_common_types, __version__
# ____________________________________________________________
import sys
-assert __version__ == "1.8.1", ("This test_c.py file is for testing a version"
+assert __version__ == "1.8.2", ("This test_c.py file is for testing a version"
" of cffi that differs from the one that we"
" get from 'import _cffi_backend'")
if sys.version_info < (3,):
diff --git a/cffi/__init__.py b/cffi/__init__.py
index 0261464..e3cfe50 100644
--- a/cffi/__init__.py
+++ b/cffi/__init__.py
@@ -4,8 +4,8 @@ __all__ = ['FFI', 'VerificationError', 'VerificationMissing', 'CDefError',
from .api import FFI, CDefError, FFIError
from .ffiplatform import VerificationError, VerificationMissing
-__version__ = "1.8.1"
-__version_info__ = (1, 8, 1)
+__version__ = "1.8.2"
+__version_info__ = (1, 8, 2)
# The verifier module file names are based on the CRC32 of a string that
# contains the following version number. It may be older than __version__
diff --git a/cffi/_embedding.h b/cffi/_embedding.h
index eb7c744..05a7903 100644
--- a/cffi/_embedding.h
+++ b/cffi/_embedding.h
@@ -233,7 +233,7 @@ static int _cffi_initialize_python(void)
f = PySys_GetObject((char *)"stderr");
if (f != NULL && f != Py_None) {
PyFile_WriteString("\nFrom: " _CFFI_MODULE_NAME
- "\ncompiled with cffi version: 1.8.1"
+ "\ncompiled with cffi version: 1.8.2"
"\n_cffi_backend module: ", f);
modules = PyImport_GetModuleDict();
mod = PyDict_GetItemString(modules, "_cffi_backend");
diff --git a/doc/source/conf.py b/doc/source/conf.py
index 9a6380a..5ddea92 100644
--- a/doc/source/conf.py
+++ b/doc/source/conf.py
@@ -47,7 +47,7 @@ copyright = u'2012-2015, Armin Rigo, Maciej Fijalkowski'
# The short X.Y version.
version = '1.8'
# The full version, including alpha/beta/rc tags.
-release = '1.8.1'
+release = '1.8.2'
# The language for content autogenerated by Sphinx. Refer to documentation
# for a list of supported languages.
diff --git a/doc/source/installation.rst b/doc/source/installation.rst
index 01a8049..eff0528 100644
--- a/doc/source/installation.rst
+++ b/doc/source/installation.rst
@@ -51,7 +51,7 @@ Requirements:
Download and Installation:
-* http://pypi.python.org/packages/source/c/cffi/cffi-1.8.1.tar.gz
+* http://pypi.python.org/packages/source/c/cffi/cffi-1.8.2.tar.gz
- MD5: ...
diff --git a/doc/source/whatsnew.rst b/doc/source/whatsnew.rst
index 2bbc60f..5e468b7 100644
--- a/doc/source/whatsnew.rst
+++ b/doc/source/whatsnew.rst
@@ -3,6 +3,15 @@ What's New
======================
+v1.8.2
+======
+
+* Issue #283: fixed ``ffi.new()`` on structures/unions with nested
+ anonymous structures/unions, when there is at least one union in
+ the mix. When initialized with a list or a dict, it should now
+ behave more closely like the ``{ }`` syntax does in GCC.
+
+
v1.8.1
======
diff --git a/setup.py b/setup.py
index a6d0489..a282545 100644
--- a/setup.py
+++ b/setup.py
@@ -144,7 +144,7 @@ Contact
`Mailing list <https://groups.google.com/forum/#!forum/python-cffi>`_
""",
- version='1.8.1',
+ version='1.8.2',
packages=['cffi'] if cpython else [],
package_data={'cffi': ['_cffi_include.h', 'parse_c_type.h',
'_embedding.h']}