summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArmin Rigo <arigo@tunes.org>2014-07-05 16:47:35 +0200
committerArmin Rigo <arigo@tunes.org>2014-07-05 16:47:35 +0200
commitd006340d73490b19a70721fbf26cd2ba738df487 (patch)
treebe2d9401b49044e8137da0e87427cfccbf86a0d6
parentbcd44b1777bae12e740e95d01f334364f0faeb57 (diff)
downloadcffi-d006340d73490b19a70721fbf26cd2ba738df487.tar.gz
prepare for 0.8.3
-rw-r--r--c/_cffi_backend.c2
-rw-r--r--c/test_c.py2
-rw-r--r--cffi/__init__.py4
-rw-r--r--doc/source/conf.py2
-rw-r--r--doc/source/index.rst2
-rw-r--r--setup.py2
6 files changed, 7 insertions, 7 deletions
diff --git a/c/_cffi_backend.c b/c/_cffi_backend.c
index 5347410..4415264 100644
--- a/c/_cffi_backend.c
+++ b/c/_cffi_backend.c
@@ -5504,7 +5504,7 @@ init_cffi_backend(void)
if (v == NULL || PyModule_AddObject(m, "_C_API", v) < 0)
INITERROR;
- v = PyText_FromString("0.8.2");
+ v = PyText_FromString("0.8.3");
if (v == NULL || PyModule_AddObject(m, "__version__", v) < 0)
INITERROR;
diff --git a/c/test_c.py b/c/test_c.py
index 83aef85..a42b9de 100644
--- a/c/test_c.py
+++ b/c/test_c.py
@@ -3199,4 +3199,4 @@ def test_packed_with_bitfields():
def test_version():
# this test is here mostly for PyPy
- assert __version__ == "0.8.2"
+ assert __version__ == "0.8.3"
diff --git a/cffi/__init__.py b/cffi/__init__.py
index fa9e86f..4c84250 100644
--- a/cffi/__init__.py
+++ b/cffi/__init__.py
@@ -4,5 +4,5 @@ __all__ = ['FFI', 'VerificationError', 'VerificationMissing', 'CDefError',
from .api import FFI, CDefError, FFIError
from .ffiplatform import VerificationError, VerificationMissing
-__version__ = "0.8.2"
-__version_info__ = (0, 8, 2)
+__version__ = "0.8.3"
+__version_info__ = (0, 8, 3)
diff --git a/doc/source/conf.py b/doc/source/conf.py
index 17bcbd3..29cdb4d 100644
--- a/doc/source/conf.py
+++ b/doc/source/conf.py
@@ -47,7 +47,7 @@ copyright = u'2012, Armin Rigo, Maciej Fijalkowski'
# The short X.Y version.
version = '0.8'
# The full version, including alpha/beta/rc tags.
-release = '0.8.2'
+release = '0.8.3'
# The language for content autogenerated by Sphinx. Refer to documentation
# for a list of supported languages.
diff --git a/doc/source/index.rst b/doc/source/index.rst
index 33cd909..146faca 100644
--- a/doc/source/index.rst
+++ b/doc/source/index.rst
@@ -88,7 +88,7 @@ Requirements:
Download and Installation:
-* http://pypi.python.org/packages/source/c/cffi/cffi-0.8.2.tar.gz
+* http://pypi.python.org/packages/source/c/cffi/cffi-0.8.3.tar.gz
- Or grab the most current version by following the instructions below.
diff --git a/setup.py b/setup.py
index d46df7a..3b7e3e1 100644
--- a/setup.py
+++ b/setup.py
@@ -113,7 +113,7 @@ Contact
`Mailing list <https://groups.google.com/forum/#!forum/python-cffi>`_
""",
- version='0.8.2',
+ version='0.8.3',
packages=['cffi'],
zip_safe=False,