summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArmin Rigo <arigo@tunes.org>2014-07-05 18:53:03 +0200
committerArmin Rigo <arigo@tunes.org>2014-07-05 18:53:03 +0200
commit0383617837184a9d57cea258a383b346013a61ab (patch)
treeb1e42acc06351d8d2ae82552c6766ab7c4d3673e
parentaec3abdfe1258d606c48d5dc65785636cf00546d (diff)
downloadcffi-0383617837184a9d57cea258a383b346013a61ab.tar.gz
Update to 0.8.4
-rw-r--r--cffi/__init__.py4
-rw-r--r--doc/source/conf.py2
-rw-r--r--doc/source/index.rst6
-rw-r--r--setup.py2
-rw-r--r--testing/test_version.py1
5 files changed, 8 insertions, 7 deletions
diff --git a/cffi/__init__.py b/cffi/__init__.py
index 4c84250..8b8121e 100644
--- a/cffi/__init__.py
+++ b/cffi/__init__.py
@@ -4,5 +4,5 @@ __all__ = ['FFI', 'VerificationError', 'VerificationMissing', 'CDefError',
from .api import FFI, CDefError, FFIError
from .ffiplatform import VerificationError, VerificationMissing
-__version__ = "0.8.3"
-__version_info__ = (0, 8, 3)
+__version__ = "0.8.4"
+__version_info__ = (0, 8, 4)
diff --git a/doc/source/conf.py b/doc/source/conf.py
index 29cdb4d..884b1dc 100644
--- a/doc/source/conf.py
+++ b/doc/source/conf.py
@@ -47,7 +47,7 @@ copyright = u'2012, Armin Rigo, Maciej Fijalkowski'
# The short X.Y version.
version = '0.8'
# The full version, including alpha/beta/rc tags.
-release = '0.8.3'
+release = '0.8.4'
# The language for content autogenerated by Sphinx. Refer to documentation
# for a list of supported languages.
diff --git a/doc/source/index.rst b/doc/source/index.rst
index aa38a08..f59f3da 100644
--- a/doc/source/index.rst
+++ b/doc/source/index.rst
@@ -88,13 +88,13 @@ Requirements:
Download and Installation:
-* http://pypi.python.org/packages/source/c/cffi/cffi-0.8.3.tar.gz
+* http://pypi.python.org/packages/source/c/cffi/cffi-0.8.4.tar.gz
- Or grab the most current version by following the instructions below.
- - MD5: 57e140a7d475f58bada8f2ada3f5749e
+ - MD5: ...
- - SHA: 4fd222f3044b9210476255d753c0bb22b8050f99
+ - SHA: ...
* Or get it from the `Bitbucket page`_:
``hg clone https://bitbucket.org/cffi/cffi``
diff --git a/setup.py b/setup.py
index 3e662b7..3603907 100644
--- a/setup.py
+++ b/setup.py
@@ -115,7 +115,7 @@ Contact
`Mailing list <https://groups.google.com/forum/#!forum/python-cffi>`_
""",
- version='0.8.3',
+ version='0.8.4',
packages=['cffi'],
zip_safe=False,
diff --git a/testing/test_version.py b/testing/test_version.py
index 6fae16f..a8db0c7 100644
--- a/testing/test_version.py
+++ b/testing/test_version.py
@@ -10,6 +10,7 @@ BACKEND_VERSIONS = {
'0.7.1': '0.7', # did not change
'0.7.2': '0.7', # did not change
'0.8.1': '0.8', # did not change (essentially)
+ '0.8.4': '0.8.3', # did not change
}
def test_version():