summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArmin Rigo <arigo@tunes.org>2014-07-05 19:12:18 +0200
committerArmin Rigo <arigo@tunes.org>2014-07-05 19:12:18 +0200
commit77b0ee29f91b568fe437cc8b96994a00ad1081aa (patch)
treef350acd5c1d5350e33ed35d95a50fe1f8c2cdab6
parentad66963ddf2eb5e9b923288a9c4daadfc66afdbf (diff)
downloadcffi-77b0ee29f91b568fe437cc8b96994a00ad1081aa.tar.gz
Argh. The version 0.8.4 works with the backend "0.8.4" or "0.8", but
not "0.8.3". As a result, the release 0.8.4 is completely unusable. Get rid of the possibility to have some different version numbers in the backend, and prepare for 0.8.5...
-rw-r--r--c/_cffi_backend.c2
-rw-r--r--c/test_c.py2
-rw-r--r--cffi/__init__.py4
-rw-r--r--cffi/api.py3
-rw-r--r--doc/source/conf.py2
-rw-r--r--doc/source/index.rst6
-rw-r--r--setup.py2
-rw-r--r--testing/test_version.py21
8 files changed, 21 insertions, 21 deletions
diff --git a/c/_cffi_backend.c b/c/_cffi_backend.c
index 4415264..0565062 100644
--- a/c/_cffi_backend.c
+++ b/c/_cffi_backend.c
@@ -5504,7 +5504,7 @@ init_cffi_backend(void)
if (v == NULL || PyModule_AddObject(m, "_C_API", v) < 0)
INITERROR;
- v = PyText_FromString("0.8.3");
+ v = PyText_FromString("0.8.5");
if (v == NULL || PyModule_AddObject(m, "__version__", v) < 0)
INITERROR;
diff --git a/c/test_c.py b/c/test_c.py
index a42b9de..50e2a3c 100644
--- a/c/test_c.py
+++ b/c/test_c.py
@@ -3199,4 +3199,4 @@ def test_packed_with_bitfields():
def test_version():
# this test is here mostly for PyPy
- assert __version__ == "0.8.3"
+ assert __version__ == "0.8.5"
diff --git a/cffi/__init__.py b/cffi/__init__.py
index 8b8121e..830901f 100644
--- a/cffi/__init__.py
+++ b/cffi/__init__.py
@@ -4,5 +4,5 @@ __all__ = ['FFI', 'VerificationError', 'VerificationMissing', 'CDefError',
from .api import FFI, CDefError, FFIError
from .ffiplatform import VerificationError, VerificationMissing
-__version__ = "0.8.4"
-__version_info__ = (0, 8, 4)
+__version__ = "0.8.5"
+__version_info__ = (0, 8, 5)
diff --git a/cffi/api.py b/cffi/api.py
index 0527a4b..aed9715 100644
--- a/cffi/api.py
+++ b/cffi/api.py
@@ -55,8 +55,7 @@ class FFI(object):
# _cffi_backend.so compiled.
import _cffi_backend as backend
from . import __version__
- assert (backend.__version__ == __version__ or
- backend.__version__ == __version__[:3])
+ assert backend.__version__ == __version__
# (If you insist you can also try to pass the option
# 'backend=backend_ctypes.CTypesBackend()', but don't
# rely on it! It's probably not going to work well.)
diff --git a/doc/source/conf.py b/doc/source/conf.py
index 884b1dc..559b810 100644
--- a/doc/source/conf.py
+++ b/doc/source/conf.py
@@ -47,7 +47,7 @@ copyright = u'2012, Armin Rigo, Maciej Fijalkowski'
# The short X.Y version.
version = '0.8'
# The full version, including alpha/beta/rc tags.
-release = '0.8.4'
+release = '0.8.5'
# The language for content autogenerated by Sphinx. Refer to documentation
# for a list of supported languages.
diff --git a/doc/source/index.rst b/doc/source/index.rst
index 0c37945..2eaaa76 100644
--- a/doc/source/index.rst
+++ b/doc/source/index.rst
@@ -88,13 +88,13 @@ Requirements:
Download and Installation:
-* http://pypi.python.org/packages/source/c/cffi/cffi-0.8.4.tar.gz
+* http://pypi.python.org/packages/source/c/cffi/cffi-0.8.5.tar.gz
- Or grab the most current version by following the instructions below.
- - MD5: 148894125d3fa696b418dc6559818f7a
+ - MD5: ...
- - SHA: 754ad62d0868bd48f34b2a5818575493e15b5514
+ - SHA: ...
* Or get it from the `Bitbucket page`_:
``hg clone https://bitbucket.org/cffi/cffi``
diff --git a/setup.py b/setup.py
index 3603907..5935d08 100644
--- a/setup.py
+++ b/setup.py
@@ -115,7 +115,7 @@ Contact
`Mailing list <https://groups.google.com/forum/#!forum/python-cffi>`_
""",
- version='0.8.4',
+ version='0.8.5',
packages=['cffi'],
zip_safe=False,
diff --git a/testing/test_version.py b/testing/test_version.py
index a8db0c7..0ea9e22 100644
--- a/testing/test_version.py
+++ b/testing/test_version.py
@@ -5,19 +5,20 @@ def setup_module(mod):
if '_cffi_backend' in sys.builtin_module_names:
py.test.skip("this is embedded version")
-BACKEND_VERSIONS = {
- '0.4.2': '0.4', # did not change
- '0.7.1': '0.7', # did not change
- '0.7.2': '0.7', # did not change
- '0.8.1': '0.8', # did not change (essentially)
- '0.8.4': '0.8.3', # did not change
- }
+#BACKEND_VERSIONS = {
+# '0.4.2': '0.4', # did not change
+# '0.7.1': '0.7', # did not change
+# '0.7.2': '0.7', # did not change
+# '0.8.1': '0.8', # did not change (essentially)
+# '0.8.4': '0.8.3', # did not change
+# }
def test_version():
v = cffi.__version__
version_info = '.'.join(str(i) for i in cffi.__version_info__)
assert v == version_info
- assert BACKEND_VERSIONS.get(v, v) == _cffi_backend.__version__
+ #v = BACKEND_VERSIONS.get(v, v)
+ assert v == _cffi_backend.__version__
def test_doc_version():
parent = os.path.dirname(os.path.dirname(__file__))
@@ -48,5 +49,5 @@ def test_c_version():
v = cffi.__version__
p = os.path.join(parent, 'c', 'test_c.py')
content = open(p).read()
- assert (('assert __version__ == "%s"' % BACKEND_VERSIONS.get(v, v))
- in content)
+ #v = BACKEND_VERSIONS.get(v, v)
+ assert (('assert __version__ == "%s"' % v) in content)