summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Davis <mrd@redhat.com>2021-09-17 15:09:29 -0700
committerMatt Davis <mrd@redhat.com>2021-09-17 15:09:29 -0700
commit38757ba567a0030bf7f1ddd3d1f3269335771ed8 (patch)
tree956d60b4819af73260bfae29fd392b1b46bbfb2a
parent4d7e8223ff1059ec5ba363b97d521d80b64dd182 (diff)
downloadcffi-38757ba567a0030bf7f1ddd3d1f3269335771ed8.tar.gz
Bump version to 1.15.0rc1
-rw-r--r--c/_cffi_backend.c2
-rw-r--r--c/test_c.py2
-rw-r--r--cffi/__init__.py4
-rw-r--r--cffi/_embedding.h2
-rw-r--r--doc/source/conf.py4
-rw-r--r--doc/source/installation.rst8
-rw-r--r--doc/source/whatsnew.rst11
-rw-r--r--setup.py2
8 files changed, 23 insertions, 12 deletions
diff --git a/c/_cffi_backend.c b/c/_cffi_backend.c
index 3e0351b..e8551e2 100644
--- a/c/_cffi_backend.c
+++ b/c/_cffi_backend.c
@@ -2,7 +2,7 @@
#include <Python.h>
#include "structmember.h"
-#define CFFI_VERSION "1.14.6"
+#define CFFI_VERSION "1.15.0rc1"
#ifdef MS_WIN32
#include <windows.h>
diff --git a/c/test_c.py b/c/test_c.py
index cd8def7..22aab0b 100644
--- a/c/test_c.py
+++ b/c/test_c.py
@@ -17,7 +17,7 @@ from _cffi_backend import __version__
# ____________________________________________________________
import sys
-assert __version__ == "1.14.6", ("This test_c.py file is for testing a version"
+assert __version__ == "1.15.0rc1", ("This test_c.py file is for testing a version"
" of cffi that differs from the one that we"
" get from 'import _cffi_backend'")
if sys.version_info < (3,):
diff --git a/cffi/__init__.py b/cffi/__init__.py
index cdc26f0..9ba8da5 100644
--- a/cffi/__init__.py
+++ b/cffi/__init__.py
@@ -5,8 +5,8 @@ from .api import FFI
from .error import CDefError, FFIError, VerificationError, VerificationMissing
from .error import PkgConfigError
-__version__ = "1.14.6"
-__version_info__ = (1, 14, 6)
+__version__ = "1.15.0rc1"
+__version_info__ = (1, 15, 0)
# The verifier module file names are based on the CRC32 of a string that
# contains the following version number. It may be older than __version__
diff --git a/cffi/_embedding.h b/cffi/_embedding.h
index 7410231..34c536c 100644
--- a/cffi/_embedding.h
+++ b/cffi/_embedding.h
@@ -224,7 +224,7 @@ static int _cffi_initialize_python(void)
if (f != NULL && f != Py_None) {
PyFile_WriteString("\nFrom: " _CFFI_MODULE_NAME
- "\ncompiled with cffi version: 1.14.6"
+ "\ncompiled with cffi version: 1.15.0rc1"
"\n_cffi_backend module: ", f);
modules = PyImport_GetModuleDict();
mod = PyDict_GetItemString(modules, "_cffi_backend");
diff --git a/doc/source/conf.py b/doc/source/conf.py
index 0b13937..9397372 100644
--- a/doc/source/conf.py
+++ b/doc/source/conf.py
@@ -45,9 +45,9 @@ copyright = u'2012-2018, Armin Rigo, Maciej Fijalkowski'
# built documents.
#
# The short X.Y version.
-version = '1.14'
+version = '1.15'
# The full version, including alpha/beta/rc tags.
-release = '1.14.6'
+release = '1.15.0rc1'
# The language for content autogenerated by Sphinx. Refer to documentation
# for a list of supported languages.
diff --git a/doc/source/installation.rst b/doc/source/installation.rst
index b587a97..01b8ff5 100644
--- a/doc/source/installation.rst
+++ b/doc/source/installation.rst
@@ -52,13 +52,13 @@ Download and Installation:
* https://pypi.python.org/pypi/cffi
-* Checksums of the "source" package version 1.14.6:
+* Checksums of the "source" package version 1.15.0rc1:
- - MD5: 5c118a18ea897df164dbff67a32876fc
+ - MD5: ...
- - SHA1: 35bb24955834ecb5b7173e625fa95b02d638fcfd
+ - SHA1: ...
- - SHA256: c9a875ce9d7fe32887784274dd533c57909b7b1dcadcc128a2ac21331a9765dd
+ - SHA256: ...
* Or grab the most current version from the `Heptapod page`_:
``hg clone https://foss.heptapod.net/pypy/cffi``
diff --git a/doc/source/whatsnew.rst b/doc/source/whatsnew.rst
index ff09168..8aa3c6e 100644
--- a/doc/source/whatsnew.rst
+++ b/doc/source/whatsnew.rst
@@ -2,6 +2,17 @@
What's New
======================
+v1.15.0rc1
+==========
+
+* CPython 3.10 support (including wheels)
+
+* MacOS arm64 support (including wheels)
+
+* Initial Windows arm64 support
+
+* Misc. doc and test updates
+
v1.14.6
=======
diff --git a/setup.py b/setup.py
index 2e7b6cb..efa82c7 100644
--- a/setup.py
+++ b/setup.py
@@ -186,7 +186,7 @@ Contact
`Mailing list <https://groups.google.com/forum/#!forum/python-cffi>`_
""",
- version='1.14.6',
+ version='1.15.0rc1',
packages=['cffi'] if cpython else [],
package_data={'cffi': ['_cffi_include.h', 'parse_c_type.h',
'_embedding.h', '_cffi_errors.h']}