summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArmin Rigo <arigo@tunes.org>2021-02-11 07:33:25 +0100
committerArmin Rigo <arigo@tunes.org>2021-02-11 07:33:25 +0100
commit64c832a8f00a9776bf93d1c99b878365fded292e (patch)
treecab2c067aed464b027be8f70a822f0b8db7e4841
parent7fbe99abfa923d052e85964dba18802bcb3714f0 (diff)
downloadcffi-64c832a8f00a9776bf93d1c99b878365fded292e.tar.gz
Bump version to 1.14.5 and add whatsnew entry
-rw-r--r--c/_cffi_backend.c2
-rw-r--r--c/test_c.py2
-rw-r--r--cffi/__init__.py4
-rw-r--r--cffi/_embedding.h2
-rw-r--r--doc/source/conf.py2
-rw-r--r--doc/source/installation.rst8
-rw-r--r--doc/source/whatsnew.rst8
-rw-r--r--setup.py2
8 files changed, 19 insertions, 11 deletions
diff --git a/c/_cffi_backend.c b/c/_cffi_backend.c
index a40ee34..23304d3 100644
--- a/c/_cffi_backend.c
+++ b/c/_cffi_backend.c
@@ -2,7 +2,7 @@
#include <Python.h>
#include "structmember.h"
-#define CFFI_VERSION "1.14.4"
+#define CFFI_VERSION "1.14.5"
#ifdef MS_WIN32
#include <windows.h>
diff --git a/c/test_c.py b/c/test_c.py
index 9c4ab4b..69ad15e 100644
--- a/c/test_c.py
+++ b/c/test_c.py
@@ -17,7 +17,7 @@ from _cffi_backend import __version__
# ____________________________________________________________
import sys
-assert __version__ == "1.14.4", ("This test_c.py file is for testing a version"
+assert __version__ == "1.14.5", ("This test_c.py file is for testing a version"
" of cffi that differs from the one that we"
" get from 'import _cffi_backend'")
if sys.version_info < (3,):
diff --git a/cffi/__init__.py b/cffi/__init__.py
index 644dea7..b79c21f 100644
--- a/cffi/__init__.py
+++ b/cffi/__init__.py
@@ -5,8 +5,8 @@ from .api import FFI
from .error import CDefError, FFIError, VerificationError, VerificationMissing
from .error import PkgConfigError
-__version__ = "1.14.4"
-__version_info__ = (1, 14, 4)
+__version__ = "1.14.5"
+__version_info__ = (1, 14, 5)
# The verifier module file names are based on the CRC32 of a string that
# contains the following version number. It may be older than __version__
diff --git a/cffi/_embedding.h b/cffi/_embedding.h
index cae179a..c36d793 100644
--- a/cffi/_embedding.h
+++ b/cffi/_embedding.h
@@ -224,7 +224,7 @@ static int _cffi_initialize_python(void)
if (f != NULL && f != Py_None) {
PyFile_WriteString("\nFrom: " _CFFI_MODULE_NAME
- "\ncompiled with cffi version: 1.14.4"
+ "\ncompiled with cffi version: 1.14.5"
"\n_cffi_backend module: ", f);
modules = PyImport_GetModuleDict();
mod = PyDict_GetItemString(modules, "_cffi_backend");
diff --git a/doc/source/conf.py b/doc/source/conf.py
index bd1f3bd..2a7e353 100644
--- a/doc/source/conf.py
+++ b/doc/source/conf.py
@@ -47,7 +47,7 @@ copyright = u'2012-2018, Armin Rigo, Maciej Fijalkowski'
# The short X.Y version.
version = '1.14'
# The full version, including alpha/beta/rc tags.
-release = '1.14.4'
+release = '1.14.5'
# The language for content autogenerated by Sphinx. Refer to documentation
# for a list of supported languages.
diff --git a/doc/source/installation.rst b/doc/source/installation.rst
index 7af2cdd..8849616 100644
--- a/doc/source/installation.rst
+++ b/doc/source/installation.rst
@@ -52,13 +52,13 @@ Download and Installation:
* https://pypi.python.org/pypi/cffi
-* Checksums of the "source" package version 1.14.4:
+* Checksums of the "source" package version 1.14.5:
- - MD5: ad3d8537b1516bad6bcdc36c458788be
+ - MD5: ...
- - SHA: 45bd57a0903a2d63b93461e096c5d291875a457b
+ - SHA: ...
- - SHA256: 1a465cbe98a7fd391d47dce4b8f7e5b921e6cd805ef421d04f5f66ba8f06086c
+ - SHA256: ...
* Or grab the most current version from the `Heptapod page`_:
``hg clone https://foss.heptapod.net/pypy/cffi``
diff --git a/doc/source/whatsnew.rst b/doc/source/whatsnew.rst
index 3ac3ac3..f6111d5 100644
--- a/doc/source/whatsnew.rst
+++ b/doc/source/whatsnew.rst
@@ -3,6 +3,14 @@ What's New
======================
+v1.14.5
+=======
+
+* Source fix for old gcc versions
+
+* This and future releases should include wheels on more platforms,
+ thanks to our new release managers Matt and Matt!
+
v1.14.4
=======
diff --git a/setup.py b/setup.py
index 902af12..c5c07b2 100644
--- a/setup.py
+++ b/setup.py
@@ -187,7 +187,7 @@ Contact
`Mailing list <https://groups.google.com/forum/#!forum/python-cffi>`_
""",
- version='1.14.4',
+ version='1.14.5',
packages=['cffi'] if cpython else [],
package_data={'cffi': ['_cffi_include.h', 'parse_c_type.h',
'_embedding.h', '_cffi_errors.h']}