summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Davis <mrd@redhat.com>2021-10-12 16:50:41 -0700
committerMatt Davis <mrd@redhat.com>2021-10-12 16:50:41 -0700
commit704961d51e426e57c1eeff23b8ba56c9871f72d1 (patch)
tree5fae14bdae753d7949b5b323d98e379f86277cdd
parent794159d44c1e8d8fdc2db6d06be97941fa7892de (diff)
downloadcffi-704961d51e426e57c1eeff23b8ba56c9871f72d1.tar.gz
Bump version to 1.15.0
-rw-r--r--c/_cffi_backend.c2
-rw-r--r--c/test_c.py2
-rw-r--r--cffi/__init__.py4
-rw-r--r--cffi/_embedding.h2
-rw-r--r--doc/source/conf.py2
-rw-r--r--doc/source/installation.rst2
-rw-r--r--doc/source/whatsnew.rst7
-rw-r--r--setup.py2
8 files changed, 10 insertions, 13 deletions
diff --git a/c/_cffi_backend.c b/c/_cffi_backend.c
index c2bd16c..ffecbf9 100644
--- a/c/_cffi_backend.c
+++ b/c/_cffi_backend.c
@@ -2,7 +2,7 @@
#include <Python.h>
#include "structmember.h"
-#define CFFI_VERSION "1.15.0rc2"
+#define CFFI_VERSION "1.15.0"
#ifdef MS_WIN32
#include <windows.h>
diff --git a/c/test_c.py b/c/test_c.py
index bcb5f32..654584d 100644
--- a/c/test_c.py
+++ b/c/test_c.py
@@ -17,7 +17,7 @@ from _cffi_backend import __version__
# ____________________________________________________________
import sys
-assert __version__ == "1.15.0rc2", ("This test_c.py file is for testing a version"
+assert __version__ == "1.15.0", ("This test_c.py file is for testing a version"
" of cffi that differs from the one that we"
" get from 'import _cffi_backend'")
if sys.version_info < (3,):
diff --git a/cffi/__init__.py b/cffi/__init__.py
index b646589..82a9618 100644
--- a/cffi/__init__.py
+++ b/cffi/__init__.py
@@ -5,8 +5,8 @@ from .api import FFI
from .error import CDefError, FFIError, VerificationError, VerificationMissing
from .error import PkgConfigError
-__version__ = "1.15.0rc2"
-__version_info__ = (1, 15, 0, 'rc2')
+__version__ = "1.15.0"
+__version_info__ = (1, 15, 0)
# The verifier module file names are based on the CRC32 of a string that
# contains the following version number. It may be older than __version__
diff --git a/cffi/_embedding.h b/cffi/_embedding.h
index a40fb07..e863d85 100644
--- a/cffi/_embedding.h
+++ b/cffi/_embedding.h
@@ -224,7 +224,7 @@ static int _cffi_initialize_python(void)
if (f != NULL && f != Py_None) {
PyFile_WriteString("\nFrom: " _CFFI_MODULE_NAME
- "\ncompiled with cffi version: 1.15.0rc2"
+ "\ncompiled with cffi version: 1.15.0"
"\n_cffi_backend module: ", f);
modules = PyImport_GetModuleDict();
mod = PyDict_GetItemString(modules, "_cffi_backend");
diff --git a/doc/source/conf.py b/doc/source/conf.py
index 76c0a32..33e8c11 100644
--- a/doc/source/conf.py
+++ b/doc/source/conf.py
@@ -47,7 +47,7 @@ copyright = u'2012-2018, Armin Rigo, Maciej Fijalkowski'
# The short X.Y version.
version = '1.15'
# The full version, including alpha/beta/rc tags.
-release = '1.15.0rc2'
+release = '1.15.0'
# The language for content autogenerated by Sphinx. Refer to documentation
# for a list of supported languages.
diff --git a/doc/source/installation.rst b/doc/source/installation.rst
index 177ac0d..69d296f 100644
--- a/doc/source/installation.rst
+++ b/doc/source/installation.rst
@@ -52,7 +52,7 @@ Download and Installation:
* https://pypi.python.org/pypi/cffi
-* Checksums of the "source" package version 1.15.0rc2:
+* Checksums of the "source" package version 1.15.0:
- MD5: ...
diff --git a/doc/source/whatsnew.rst b/doc/source/whatsnew.rst
index a99af6b..aa7f2fe 100644
--- a/doc/source/whatsnew.rst
+++ b/doc/source/whatsnew.rst
@@ -2,8 +2,8 @@
What's New
======================
-v1.15.0rc2
-==========
+v1.15.0
+=======
* Fixed MANIFEST.in to include missing file for Windows arm64 support
@@ -11,9 +11,6 @@ v1.15.0rc2
* Updated setup.py Python trove specifiers to currently-tested Python versions
-v1.15.0rc1
-==========
-
* CPython 3.10 support (including wheels)
* MacOS arm64 support (including wheels)
diff --git a/setup.py b/setup.py
index 5cd4845..5fd1a1c 100644
--- a/setup.py
+++ b/setup.py
@@ -186,7 +186,7 @@ Contact
`Mailing list <https://groups.google.com/forum/#!forum/python-cffi>`_
""",
- version='1.15.0rc2',
+ version='1.15.0',
packages=['cffi'] if cpython else [],
package_data={'cffi': ['_cffi_include.h', 'parse_c_type.h',
'_embedding.h', '_cffi_errors.h']}