summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Davis <mrd@redhat.com>2021-10-04 19:21:58 -0700
committerMatt Davis <mrd@redhat.com>2021-10-04 19:21:58 -0700
commit794159d44c1e8d8fdc2db6d06be97941fa7892de (patch)
tree6ed8d19d9ed068d372a8ed6e22766c24b5a57861
parent146be2f3da7b83a1091402c518963a5d4fe5df1d (diff)
downloadcffi-794159d44c1e8d8fdc2db6d06be97941fa7892de.tar.gz
Bump version to 1.15.0rc2
-rw-r--r--README.md2
-rw-r--r--c/_cffi_backend.c2
-rw-r--r--c/test_c.py2
-rw-r--r--cffi/__init__.py4
-rw-r--r--cffi/_embedding.h2
-rw-r--r--doc/source/conf.py2
-rw-r--r--doc/source/installation.rst8
-rw-r--r--doc/source/whatsnew.rst9
-rw-r--r--setup.py11
9 files changed, 25 insertions, 17 deletions
diff --git a/README.md b/README.md
index 3e7862d..a68639e 100644
--- a/README.md
+++ b/README.md
@@ -8,7 +8,7 @@ in the doc/ subdirectory.
Download
--------
-[Download page](https://bitbucket.org/cffi/cffi/downloads)
+[Download page](https://foss.heptapod.net/pypy/cffi/-/tags)
Contact
-------
diff --git a/c/_cffi_backend.c b/c/_cffi_backend.c
index e8551e2..c2bd16c 100644
--- a/c/_cffi_backend.c
+++ b/c/_cffi_backend.c
@@ -2,7 +2,7 @@
#include <Python.h>
#include "structmember.h"
-#define CFFI_VERSION "1.15.0rc1"
+#define CFFI_VERSION "1.15.0rc2"
#ifdef MS_WIN32
#include <windows.h>
diff --git a/c/test_c.py b/c/test_c.py
index 22aab0b..bcb5f32 100644
--- a/c/test_c.py
+++ b/c/test_c.py
@@ -17,7 +17,7 @@ from _cffi_backend import __version__
# ____________________________________________________________
import sys
-assert __version__ == "1.15.0rc1", ("This test_c.py file is for testing a version"
+assert __version__ == "1.15.0rc2", ("This test_c.py file is for testing a version"
" of cffi that differs from the one that we"
" get from 'import _cffi_backend'")
if sys.version_info < (3,):
diff --git a/cffi/__init__.py b/cffi/__init__.py
index 8ed951d..b646589 100644
--- a/cffi/__init__.py
+++ b/cffi/__init__.py
@@ -5,8 +5,8 @@ from .api import FFI
from .error import CDefError, FFIError, VerificationError, VerificationMissing
from .error import PkgConfigError
-__version__ = "1.15.0rc1"
-__version_info__ = (1, 15, 0, 'rc1')
+__version__ = "1.15.0rc2"
+__version_info__ = (1, 15, 0, 'rc2')
# The verifier module file names are based on the CRC32 of a string that
# contains the following version number. It may be older than __version__
diff --git a/cffi/_embedding.h b/cffi/_embedding.h
index 34c536c..a40fb07 100644
--- a/cffi/_embedding.h
+++ b/cffi/_embedding.h
@@ -224,7 +224,7 @@ static int _cffi_initialize_python(void)
if (f != NULL && f != Py_None) {
PyFile_WriteString("\nFrom: " _CFFI_MODULE_NAME
- "\ncompiled with cffi version: 1.15.0rc1"
+ "\ncompiled with cffi version: 1.15.0rc2"
"\n_cffi_backend module: ", f);
modules = PyImport_GetModuleDict();
mod = PyDict_GetItemString(modules, "_cffi_backend");
diff --git a/doc/source/conf.py b/doc/source/conf.py
index 9397372..76c0a32 100644
--- a/doc/source/conf.py
+++ b/doc/source/conf.py
@@ -47,7 +47,7 @@ copyright = u'2012-2018, Armin Rigo, Maciej Fijalkowski'
# The short X.Y version.
version = '1.15'
# The full version, including alpha/beta/rc tags.
-release = '1.15.0rc1'
+release = '1.15.0rc2'
# The language for content autogenerated by Sphinx. Refer to documentation
# for a list of supported languages.
diff --git a/doc/source/installation.rst b/doc/source/installation.rst
index 2ae8c15..177ac0d 100644
--- a/doc/source/installation.rst
+++ b/doc/source/installation.rst
@@ -52,13 +52,13 @@ Download and Installation:
* https://pypi.python.org/pypi/cffi
-* Checksums of the "source" package version 1.15.0rc1:
+* Checksums of the "source" package version 1.15.0rc2:
- - MD5: a940f767eaf54dddf174226982ec1a8e
+ - MD5: ...
- - SHA1: aee6f9ba045551a1f7b2660930e28fb8a9a8ba4d
+ - SHA1: ...
- - SHA256: 8a2b1001ece83aabd818d334659a97cf3c0158501442f20fee7305c8ac3059cb
+ - SHA256: ...
* Or grab the most current version from the `Heptapod page`_:
``hg clone https://foss.heptapod.net/pypy/cffi``
diff --git a/doc/source/whatsnew.rst b/doc/source/whatsnew.rst
index 8aa3c6e..a99af6b 100644
--- a/doc/source/whatsnew.rst
+++ b/doc/source/whatsnew.rst
@@ -2,6 +2,15 @@
What's New
======================
+v1.15.0rc2
+==========
+
+* Fixed MANIFEST.in to include missing file for Windows arm64 support
+
+* Fixed Linux wheel build to use gcc default ISA for libffi
+
+* Updated setup.py Python trove specifiers to currently-tested Python versions
+
v1.15.0rc1
==========
diff --git a/setup.py b/setup.py
index efa82c7..5cd4845 100644
--- a/setup.py
+++ b/setup.py
@@ -186,7 +186,7 @@ Contact
`Mailing list <https://groups.google.com/forum/#!forum/python-cffi>`_
""",
- version='1.15.0rc1',
+ version='1.15.0rc2',
packages=['cffi'] if cpython else [],
package_data={'cffi': ['_cffi_include.h', 'parse_c_type.h',
'_embedding.h', '_cffi_errors.h']}
@@ -224,14 +224,13 @@ Contact
classifiers=[
'Programming Language :: Python',
'Programming Language :: Python :: 2',
- 'Programming Language :: Python :: 2.6',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.2',
- 'Programming Language :: Python :: 3.3',
- 'Programming Language :: Python :: 3.4',
- 'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3.7',
+ 'Programming Language :: Python :: 3.8',
+ 'Programming Language :: Python :: 3.9',
+ 'Programming Language :: Python :: 3.10',
'Programming Language :: Python :: Implementation :: CPython',
'Programming Language :: Python :: Implementation :: PyPy',
'License :: OSI Approved :: MIT License',