summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArmin Rigo <arigo@tunes.org>2020-07-26 17:39:41 +0200
committerArmin Rigo <arigo@tunes.org>2020-07-26 17:39:41 +0200
commitbeb98d82131ee9118af8f68376346b08fe67f258 (patch)
tree09cc472cb5666bcab1b705a0f41bb821848fff6d
parent4b7ad14fc34747bd7d7b708a9af7bdbae66791f6 (diff)
downloadcffi-beb98d82131ee9118af8f68376346b08fe67f258.tar.gz
bump version number to 1.14.1
-rw-r--r--c/_cffi_backend.c2
-rw-r--r--c/test_c.py2
-rw-r--r--cffi/__init__.py4
-rw-r--r--cffi/_embedding.h2
-rw-r--r--doc/source/conf.py2
-rw-r--r--doc/source/installation.rst8
-rw-r--r--setup.py2
7 files changed, 11 insertions, 11 deletions
diff --git a/c/_cffi_backend.c b/c/_cffi_backend.c
index e6adf3c..7768947 100644
--- a/c/_cffi_backend.c
+++ b/c/_cffi_backend.c
@@ -2,7 +2,7 @@
#include <Python.h>
#include "structmember.h"
-#define CFFI_VERSION "1.14.0"
+#define CFFI_VERSION "1.14.1"
#ifdef MS_WIN32
#include <windows.h>
diff --git a/c/test_c.py b/c/test_c.py
index 383bca2..97e7719 100644
--- a/c/test_c.py
+++ b/c/test_c.py
@@ -19,7 +19,7 @@ from _cffi_backend import __version__
# ____________________________________________________________
import sys
-assert __version__ == "1.14.0", ("This test_c.py file is for testing a version"
+assert __version__ == "1.14.1", ("This test_c.py file is for testing a version"
" of cffi that differs from the one that we"
" get from 'import _cffi_backend'")
if sys.version_info < (3,):
diff --git a/cffi/__init__.py b/cffi/__init__.py
index 7969abf..951a2b1 100644
--- a/cffi/__init__.py
+++ b/cffi/__init__.py
@@ -5,8 +5,8 @@ from .api import FFI
from .error import CDefError, FFIError, VerificationError, VerificationMissing
from .error import PkgConfigError
-__version__ = "1.14.0"
-__version_info__ = (1, 14, 0)
+__version__ = "1.14.1"
+__version_info__ = (1, 14, 1)
# The verifier module file names are based on the CRC32 of a string that
# contains the following version number. It may be older than __version__
diff --git a/cffi/_embedding.h b/cffi/_embedding.h
index e49c290..b6fe359 100644
--- a/cffi/_embedding.h
+++ b/cffi/_embedding.h
@@ -224,7 +224,7 @@ static int _cffi_initialize_python(void)
if (f != NULL && f != Py_None) {
PyFile_WriteString("\nFrom: " _CFFI_MODULE_NAME
- "\ncompiled with cffi version: 1.14.0"
+ "\ncompiled with cffi version: 1.14.1"
"\n_cffi_backend module: ", f);
modules = PyImport_GetModuleDict();
mod = PyDict_GetItemString(modules, "_cffi_backend");
diff --git a/doc/source/conf.py b/doc/source/conf.py
index d5c768b..414bf4d 100644
--- a/doc/source/conf.py
+++ b/doc/source/conf.py
@@ -47,7 +47,7 @@ copyright = u'2012-2018, Armin Rigo, Maciej Fijalkowski'
# The short X.Y version.
version = '1.14'
# The full version, including alpha/beta/rc tags.
-release = '1.14.0'
+release = '1.14.1'
# The language for content autogenerated by Sphinx. Refer to documentation
# for a list of supported languages.
diff --git a/doc/source/installation.rst b/doc/source/installation.rst
index 82fcb0e..72c4cd0 100644
--- a/doc/source/installation.rst
+++ b/doc/source/installation.rst
@@ -52,13 +52,13 @@ Download and Installation:
* https://pypi.python.org/pypi/cffi
-* Checksums of the "source" package version 1.14.0:
+* Checksums of the "source" package version 1.14.1:
- - MD5: 74845f8d2b7b583dd9a3574f402edf39
+ - MD5: ...
- - SHA: 2a8f05a7d51d77ef1e641cb359a54e4d8fa019cb
+ - SHA: ...
- - SHA256: 2d384f4a127a15ba701207f7639d94106693b6cd64173d6c8988e2c25f3ac2b6
+ - SHA256: ...
* Or grab the most current version from the `Heptapod page`_:
``hg clone https://foss.heptapod.net/pypy/cffi``
diff --git a/setup.py b/setup.py
index 8216851..a673560 100644
--- a/setup.py
+++ b/setup.py
@@ -212,7 +212,7 @@ Contact
`Mailing list <https://groups.google.com/forum/#!forum/python-cffi>`_
""",
- version='1.14.0',
+ version='1.14.1',
packages=['cffi'] if cpython else [],
package_data={'cffi': ['_cffi_include.h', 'parse_c_type.h',
'_embedding.h', '_cffi_errors.h']}