summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLawrence D'Anna <lawrence_danna@apple.com>2020-07-10 10:41:35 -0700
committerLawrence D'Anna <lawrence_danna@apple.com>2020-07-10 10:41:35 -0700
commitf505faad51bf7ea87b4dcf879bdd848a59c43ddb (patch)
tree76abfcbac3efe19615aa8d7197fcf7e411a44e0d
parent549b877275d9104cc313a0b714548b58cb3fdd69 (diff)
downloadcffi-f505faad51bf7ea87b4dcf879bdd848a59c43ddb.tar.gz
Backed out changeset 9dd88cced01c
-rw-r--r--c/_cffi_backend.c2
-rw-r--r--setup.py2
2 files changed, 2 insertions, 2 deletions
diff --git a/c/_cffi_backend.c b/c/_cffi_backend.c
index ed89753..5c5fe45 100644
--- a/c/_cffi_backend.c
+++ b/c/_cffi_backend.c
@@ -84,7 +84,7 @@
* known that on the NetBSD kernel, a different strategy is used which
* should not be open to the fork() bug.
*/
-#if defined(__NetBSD__) || (CFFI_LIBFFI_FROM_MACOS && (defined(__arm__) || defined(__arm64__)))
+#ifdef __NetBSD__
# define CFFI_TRUST_LIBFFI
#endif
diff --git a/setup.py b/setup.py
index 217504a..fc8d705 100644
--- a/setup.py
+++ b/setup.py
@@ -152,7 +152,7 @@ else:
if 'darwin' in sys.platform and macosx_deployment_target() >= (10, 15):
# use libffi from Mac OS SDK
extra_compile_args += ['-iwithsysroot/usr/include/ffi']
- define_macros += [('CFFI_LIBFFI_FROM_MACOS', '1'),
+ define_macros += [('CFFI_TRUST_LIBFFI', '1'),
('HAVE_FFI_PREP_CIF_VAR', '1')]
libraries += ['ffi']
else: