summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArmin Rigo <arigo@tunes.org>2020-09-15 08:09:35 +0200
committerArmin Rigo <arigo@tunes.org>2020-09-15 08:09:35 +0200
commitb3f8e90eb126b9edb312cf39033593942f9c6a2a (patch)
tree5ae2b98846989b6c4d3e0c8b1df147bc93a26fee
parente885fdcc35aaba254228bd10f33dc92ed6baf579 (diff)
parentff3dfb69b4342b1caacfef88e705de86f5bb9844 (diff)
downloadcffi-b3f8e90eb126b9edb312cf39033593942f9c6a2a.tar.gz
hg merge release-1.14
-rw-r--r--c/_cffi_backend.c2
-rw-r--r--c/test_c.py2
-rw-r--r--cffi/__init__.py4
-rw-r--r--cffi/_embedding.h2
-rw-r--r--doc/source/conf.py2
-rw-r--r--doc/source/installation.rst8
-rw-r--r--setup.py2
7 files changed, 11 insertions, 11 deletions
diff --git a/c/_cffi_backend.c b/c/_cffi_backend.c
index 5693eaf..88e8379 100644
--- a/c/_cffi_backend.c
+++ b/c/_cffi_backend.c
@@ -2,7 +2,7 @@
#include <Python.h>
#include "structmember.h"
-#define CFFI_VERSION "1.14.2"
+#define CFFI_VERSION "1.14.3"
#ifdef MS_WIN32
#include <windows.h>
diff --git a/c/test_c.py b/c/test_c.py
index 14d3f66..fa24676 100644
--- a/c/test_c.py
+++ b/c/test_c.py
@@ -17,7 +17,7 @@ from _cffi_backend import __version__
# ____________________________________________________________
import sys
-assert __version__ == "1.14.2", ("This test_c.py file is for testing a version"
+assert __version__ == "1.14.3", ("This test_c.py file is for testing a version"
" of cffi that differs from the one that we"
" get from 'import _cffi_backend'")
if sys.version_info < (3,):
diff --git a/cffi/__init__.py b/cffi/__init__.py
index acf959c..264afa1 100644
--- a/cffi/__init__.py
+++ b/cffi/__init__.py
@@ -5,8 +5,8 @@ from .api import FFI
from .error import CDefError, FFIError, VerificationError, VerificationMissing
from .error import PkgConfigError
-__version__ = "1.14.2"
-__version_info__ = (1, 14, 2)
+__version__ = "1.14.3"
+__version_info__ = (1, 14, 3)
# The verifier module file names are based on the CRC32 of a string that
# contains the following version number. It may be older than __version__
diff --git a/cffi/_embedding.h b/cffi/_embedding.h
index 456dc52..fdce222 100644
--- a/cffi/_embedding.h
+++ b/cffi/_embedding.h
@@ -224,7 +224,7 @@ static int _cffi_initialize_python(void)
if (f != NULL && f != Py_None) {
PyFile_WriteString("\nFrom: " _CFFI_MODULE_NAME
- "\ncompiled with cffi version: 1.14.2"
+ "\ncompiled with cffi version: 1.14.3"
"\n_cffi_backend module: ", f);
modules = PyImport_GetModuleDict();
mod = PyDict_GetItemString(modules, "_cffi_backend");
diff --git a/doc/source/conf.py b/doc/source/conf.py
index 6279ac6..2315b93 100644
--- a/doc/source/conf.py
+++ b/doc/source/conf.py
@@ -47,7 +47,7 @@ copyright = u'2012-2018, Armin Rigo, Maciej Fijalkowski'
# The short X.Y version.
version = '1.14'
# The full version, including alpha/beta/rc tags.
-release = '1.14.2'
+release = '1.14.3'
# The language for content autogenerated by Sphinx. Refer to documentation
# for a list of supported languages.
diff --git a/doc/source/installation.rst b/doc/source/installation.rst
index 0be816f..3c010bc 100644
--- a/doc/source/installation.rst
+++ b/doc/source/installation.rst
@@ -52,13 +52,13 @@ Download and Installation:
* https://pypi.python.org/pypi/cffi
-* Checksums of the "source" package version 1.14.2:
+* Checksums of the "source" package version 1.14.3:
- - MD5: 3cc2f1daf62dd66eda79b4d6281cebfc
+ - MD5: c2a47ffd5d183b193ac8ed3414dcfd07
- - SHA: 6d2f277d1f1e3d9a09fc5df4bfcea63229e8e8d1
+ - SHA: 7199374653c1927e8d3c523b6498b149acdb6f7e
- - SHA256: ae8f34d50af2c2154035984b8b5fc5d9ed63f32fe615646ab435b05b132ca91b
+ - SHA256: f92f789e4f9241cd262ad7a555ca2c648a98178a953af117ef7fad46aa1d5591
* Or grab the most current version from the `Heptapod page`_:
``hg clone https://foss.heptapod.net/pypy/cffi``
diff --git a/setup.py b/setup.py
index 6812e9f..826216d 100644
--- a/setup.py
+++ b/setup.py
@@ -212,7 +212,7 @@ Contact
`Mailing list <https://groups.google.com/forum/#!forum/python-cffi>`_
""",
- version='1.14.2',
+ version='1.14.3',
packages=['cffi'] if cpython else [],
package_data={'cffi': ['_cffi_include.h', 'parse_c_type.h',
'_embedding.h', '_cffi_errors.h']}