summaryrefslogtreecommitdiff
path: root/README.md
diff options
context:
space:
mode:
authorMiro Hrončok <miro@hroncok.cz>2022-11-11 14:51:14 +0100
committerMiro Hrončok <miro@hroncok.cz>2022-11-11 14:51:14 +0100
commitbabc98d98570b5dbb85fb1c58b012aafa9769696 (patch)
treeced2689aa8dcc7f36546160934fcc5de82e41c19 /README.md
parent5ddf2accf50f05c8962c0c38211b0ad73412be71 (diff)
downloadcffi-babc98d98570b5dbb85fb1c58b012aafa9769696.tar.gz
Replace py.test usage with pytest, explicitly require py for testspy.test
pytest 7.2+ no longer depends on py. It ships py.path and py.error only. See https://docs.pytest.org/en/7.2.x/changelog.html#deprecations The tests use py.code as well, hence we declare and document a test dependency on py.
Diffstat (limited to 'README.md')
-rw-r--r--README.md4
1 files changed, 2 insertions, 2 deletions
diff --git a/README.md b/README.md
index b56afb7..b4b8488 100644
--- a/README.md
+++ b/README.md
@@ -30,10 +30,10 @@ Testing/development tips
To run tests under CPython, run::
- pip install pytest # if you don't have py.test already
+ pip install pytest py # if you don't have pytest and py already
pip install pycparser
python setup.py build_ext -f -i
- py.test c/ testing/
+ pytest c/ testing/
If you run in another directory (either the tests or another program),
you should use the environment variable ``PYTHONPATH=/path`` to point